package/gnutls: make the OpenSSL compatibility library optional
authorCarlos Santos <unixmania@gmail.com>
Thu, 15 Aug 2019 22:19:33 +0000 (19:19 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 17 Aug 2019 13:37:47 +0000 (15:37 +0200)
Add a BR2_PACKAGE_GNUTLS_OPENSSL option, disabled by default since it is
not used by any package that depends on gnutls.

The library is licensed under GPLv3, which can be a problem for embedded
systems due to the so-called anti-tivoization clause.

Signed-off-by: Carlos Santos <unixmania@gmail.com>
[Thomas: don't repeat the license details for the gnutls-openssl case,
simply append to them]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gnutls/Config.in
package/gnutls/gnutls.mk

index 7e8dcc1e4f8b3166dd8cf00c6bf9800aa4af813d..15b930b6bd5b016336475f693cde5fdda04dc1b2 100644 (file)
@@ -16,6 +16,11 @@ config BR2_PACKAGE_GNUTLS
 
 if BR2_PACKAGE_GNUTLS
 
+config BR2_PACKAGE_GNUTLS_OPENSSL
+       bool "OpenSSL compatibility library"
+       help
+         Install OpenSSL compatibility library.
+
 config BR2_PACKAGE_GNUTLS_TOOLS
        bool "install tools"
        select BR2_PACKAGE_ARGP_STANDALONE \
index 4f40b896ff391193298ac00ac537d63bcdfb79cc..700737050d9ada53556096999ef3ed8a43b0cf74 100644 (file)
@@ -8,8 +8,14 @@ GNUTLS_VERSION_MAJOR = 3.6
 GNUTLS_VERSION = $(GNUTLS_VERSION_MAJOR).8
 GNUTLS_SOURCE = gnutls-$(GNUTLS_VERSION).tar.xz
 GNUTLS_SITE = https://www.gnupg.org/ftp/gcrypt/gnutls/v$(GNUTLS_VERSION_MAJOR)
-GNUTLS_LICENSE = LGPL-2.1+ (core library), GPL-3.0+ (gnutls-openssl library)
-GNUTLS_LICENSE_FILES = doc/COPYING doc/COPYING.LESSER
+GNUTLS_LICENSE = LGPL-2.1+ (core library)
+GNUTLS_LICENSE_FILES = doc/COPYING.LESSER
+
+ifeq ($(BR2_PACKAGE_GNUTLS_OPENSSL),y)
+GNUTLS_LICENSE := $(GNUTLS_LICENSE), GPL-3.0+ (gnutls-openssl library)
+GNUTLS_LICENSE_FILES += doc/COPYING
+endif
+
 GNUTLS_DEPENDENCIES = host-pkgconf libtasn1 nettle pcre
 GNUTLS_CONF_OPTS = \
        --disable-doc \
@@ -20,6 +26,7 @@ GNUTLS_CONF_OPTS = \
        --enable-openssl-compatibility \
        --with-librt-prefix=$(STAGING_DIR) \
        --without-tpm \
+       $(if $(BR2_PACKAGE_GNUTLS_OPENSSL),--enable,--disable)-openssl-compatibility \
        $(if $(BR2_PACKAGE_GNUTLS_TOOLS),--enable-tools,--disable-tools)
 GNUTLS_CONF_ENV = gl_cv_socket_ipv6=yes \
        ac_cv_header_wchar_h=$(if $(BR2_USE_WCHAR),yes,no) \