package/orc: bump to version 0.4.31
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 4 Jan 2020 18:15:32 +0000 (19:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Feb 2020 18:36:18 +0000 (19:36 +0100)
Switch to meson buildsystem and so drop:
 - !BR2_BINFMT_FLAT dependency
 - hooks (not needed thanks to orc-test and tools options)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/orc/Config.in
package/orc/orc.hash
package/orc/orc.mk

index 7943ecfbfb230abdad8db277beceb0bc2d0fa2da..90f2b32624d1b905bd6d53009f64574f81f5488b 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_ORC
        bool "orc"
        depends on BR2_TOOLCHAIN_HAS_THREADS
-       depends on !BR2_BINFMT_FLAT # configure doesn't know uclinux
        help
          Orc is a library and set of tools for compiling and executing
          very simple programs that operate on arrays of data.
@@ -10,4 +9,3 @@ config BR2_PACKAGE_ORC
 
 comment "orc needs a toolchain w/ threads"
        depends on !BR2_TOOLCHAIN_HAS_THREADS
-       depends on !BR2_BINFMT_FLAT
index 71dd3007ca68c677982a797ad34ab247365e1e0b..c30a50112c5da98d161bd9550c95787028176328 100644 (file)
@@ -1,5 +1,5 @@
-# From https://gstreamer.freedesktop.org/src/orc/orc-0.4.27.tar.xz.sha256sum
-sha256 4f8901f9144b5ec17dffdb33548b5f4c7f8049b0d1023be3462cdd64ec5a3ab2  orc-0.4.29.tar.xz
+# From https://gstreamer.freedesktop.org/src/orc/orc-0.4.31.tar.xz.sha256sum
+sha256 a0ab5f10a6a9ae7c3a6b4218246564c3bf00d657cbdf587e6d34ec3ef0616075  orc-0.4.31.tar.xz
 
 # Locally calculated
 sha256 4f5dabb1b44bb6fc5cd53820b1f103147ad61b395a57903991325bd1b85d97bf  COPYING
index d121266bce6e8329b023bfe9981d49fcc61566ae..51a9b78482940c2d778575c724007ffea5f0718e 100644 (file)
@@ -4,24 +4,20 @@
 #
 ################################################################################
 
-ORC_VERSION = 0.4.29
+ORC_VERSION = 0.4.31
 ORC_SOURCE = orc-$(ORC_VERSION).tar.xz
 ORC_SITE = http://gstreamer.freedesktop.org/data/src/orc
 ORC_LICENSE = BSD-2-Clause, BSD-3-Clause
 ORC_LICENSE_FILES = COPYING
 ORC_INSTALL_STAGING = YES
 ORC_DEPENDENCIES = host-orc
+ORC_CONF_OPTS = \
+       -Dbenchmarks=disabled \
+       -Dexamples=disabled \
+       -Dgtk_doc=disabled \
+       -Dorc-test=disabled \
+       -Dtests=disabled \
+       -Dtools=disabled
 
-define ORC_REMOVE_BUGREPORT
-       rm -f $(TARGET_DIR)/usr/bin/orc-bugreport
-endef
-
-define ORC_REMOVE_DEVFILES
-       rm -f $(TARGET_DIR)/usr/bin/orcc
-endef
-
-ORC_POST_INSTALL_TARGET_HOOKS += ORC_REMOVE_BUGREPORT
-ORC_POST_INSTALL_TARGET_HOOKS += ORC_REMOVE_DEVFILES
-
-$(eval $(autotools-package))
-$(eval $(host-autotools-package))
+$(eval $(meson-package))
+$(eval $(host-meson-package))