package/lcms2: disable tiff
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 15 Feb 2021 17:28:48 +0000 (18:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 16 Feb 2021 20:05:13 +0000 (21:05 +0100)
tiff is only used by tificc sample and upstream rejected the patch to
fix the static build failure because "adding pkg-config dependency for a
sample is an overkill": https://github.com/mm2/Little-CMS/pull/244

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lcms2/lcms2.mk

index 862fdd5896aca6066cbb4be8a2ed63f22164ca1d..44b9965a804fec0fff0eea7f803e2456159f9068 100644 (file)
@@ -11,6 +11,8 @@ LCMS2_LICENSE_FILES = COPYING
 LCMS2_CPE_ID_VENDOR = littlecms
 LCMS2_CPE_ID_PRODUCT = little_cms
 LCMS2_INSTALL_STAGING = YES
+# tiff is only used by tificc sample
+LCMS2_CONF_OPTS = --without-tiff
 
 ifeq ($(BR2_PACKAGE_JPEG),y)
 LCMS2_CONF_OPTS += --with-jpeg
@@ -19,13 +21,6 @@ else
 LCMS2_CONF_OPTS += --without-jpeg
 endif
 
-ifeq ($(BR2_PACKAGE_TIFF),y)
-LCMS2_CONF_OPTS += --with-tiff
-LCMS2_DEPENDENCIES += tiff
-else
-LCMS2_CONF_OPTS += --without-tiff
-endif
-
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 LCMS2_CONF_OPTS += --with-zlib
 LCMS2_DEPENDENCIES += zlib