Fix Qtopia build with external toolchain
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 25 Jun 2009 08:43:24 +0000 (10:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Jul 2009 08:30:29 +0000 (10:30 +0200)
The fixes made to qmake.conf for the cross-compiling tools were not
sufficient in the case of an external toolchain, since the CFLAGS were
not taken into account. And the --sysroot option contained in the
CFLAGS are very important for external toolchains to work.

Additionally, it makes sure that Qtopia is compiled with the proper
CFLAGS, even if an external toolchain isn't used.

package/qtopia4/qtopia4.mk

index a198a41bd7d553a00dfdb491501a31f3ab767ecc..fb027dceebe5cd8282a77afbf18e2a7ce57fd392 100644 (file)
@@ -440,6 +440,8 @@ endif
        $(call QTOPIA4_QMAKE_SET,OBJCOPY,$(TARGET_OBJCOPY))
        $(call QTOPIA4_QMAKE_SET,RANLIB,$(TARGET_RANLIB))
        $(call QTOPIA4_QMAKE_SET,STRIP,$(TARGET_STRIP))
+       $(call QTOPIA4_QMAKE_SET,CFLAGS,$(TARGET_CFLAGS))
+       $(call QTOPIA4_QMAKE_SET,CXXFLAGS,$(TARGET_CXXFLAGS))
        -[ -f $(QTOPIA4_QCONFIG_FILE) ] && cp $(QTOPIA4_QCONFIG_FILE) \
                $(QTOPIA4_TARGET_DIR)/$(QTOPIA4_QCONFIG_FILE_LOCATION)
 # Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.