package/gcr: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Wed, 1 Apr 2020 00:21:28 +0000 (17:21 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:35:24 +0000 (22:35 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt --with-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gcr/gcr.mk

index 2fe583978c9174634415bb1953cdc3ce6bafe170..56bfe1110a2ecbfa995e9db46dca8d9a98c2d5d4 100644 (file)
@@ -23,6 +23,13 @@ GCR_CONF_OPTS = \
 GCR_LICENSE = LGPL-2.1+
 GCR_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+GCR_DEPENDENCIES += gobject-introspection
+GCR_CONF_OPTS += --with-introspection
+else
+GCR_CONF_OPTS += --without-introspection
+endif
+
 # Only the X11 backend is supported for the simple GUI
 ifeq ($(BR2_PACKAGE_LIBGTK3_X11),y)
 GCR_DEPENDENCIES += libgtk3