package/systemd: add dns-over-tls support
authorJames Hilliard <james.hilliard1@gmail.com>
Sun, 8 Mar 2020 08:41:31 +0000 (01:41 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Mar 2020 14:06:01 +0000 (15:06 +0100)
Set default-dns-over-tls to opportunistic when dns-over-tls is enabled
as it should be fully backwards compatible. The DNSOverTLS config in
resolved.conf can be used to override default-dns-over-tls.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/systemd.mk

index 1c3b81cfcbbe9c0ce5d2b232f91cf69f9c1a628d..d97336b7cde4c57aae2a11d2a110abf5e83aa25a 100644 (file)
@@ -351,6 +351,16 @@ else
 SYSTEMD_CONF_OPTS += -Dresolve=false
 endif
 
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+SYSTEMD_CONF_OPTS += -Ddns-over-tls=gnutls -Ddefault-dns-over-tls=opportunistic
+SYSTEMD_DEPENDENCIES += gnutls
+else ifeq ($(BR2_PACKAGE_OPENSSL),y)
+SYSTEMD_CONF_OPTS += -Ddns-over-tls=openssl -Ddefault-dns-over-tls=opportunistic
+SYSTEMD_DEPENDENCIES += openssl
+else
+SYSTEMD_CONF_OPTS += -Ddns-over-tls=false -Ddefault-dns-over-tls=no
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_TIMESYNCD),y)
 SYSTEMD_CONF_OPTS += -Dtimesyncd=true
 SYSTEMD_TIMESYNCD_USER = systemd-timesync -1 systemd-timesync -1 * - - - Network Time Synchronization