package/watchdog: new package
authorAlejandro González <alejandro.gonzalez.correo@gmail.com>
Sat, 8 Aug 2020 21:48:15 +0000 (23:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 29 Aug 2020 12:30:05 +0000 (14:30 +0200)
watchdog is a flexible watchdog daemon that improves on the already
available Busybox watchdog daemon by providing more advanced features,
like defining custom system status checks and executing repair scripts
to react upon invariants that don't hold.

Due to "watchdog" being also provided by Busybox, we need to make that
package/watchdog installs the watchdog binary in the same place as
Busybox (i.e in /sbin), and need to add a dependency of Busybox on
this new watchdog package.

Signed-off-by: Alejandro González <alejandro.gonzalez.correo@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/Config.in
package/busybox/busybox.mk
package/watchdog/Config.in [new file with mode: 0644]
package/watchdog/watchdog.hash [new file with mode: 0644]
package/watchdog/watchdog.mk [new file with mode: 0644]

index a29bd7ab99c816a45b168a29e62755e93e00a2c7..8b3b1dec6ad85cb4e374996203a9f3f52e5facab 100644 (file)
@@ -2433,6 +2433,7 @@ menu "System tools"
        source "package/tpm2-totp/Config.in"
        source "package/unscd/Config.in"
        source "package/util-linux/Config.in"
+       source "package/watchdog/Config.in"
        source "package/xdg-dbus-proxy/Config.in"
        source "package/xen/Config.in"
        source "package/xvisor/Config.in"
index e049bce81db70d8c81512f710bbc653f5458b013..7862beb790e05542631d0d941cdd942d1969f074 100644 (file)
@@ -67,6 +67,7 @@ BUSYBOX_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_USBUTILS),usbutils) \
        $(if $(BR2_PACKAGE_UTIL_LINUX),util-linux) \
        $(if $(BR2_PACKAGE_VIM),vim) \
+       $(if $(BR2_PACKAGE_WATCHDOG),watchdog) \
        $(if $(BR2_PACKAGE_WGET),wget) \
        $(if $(BR2_PACKAGE_WHOIS),whois)
 
diff --git a/package/watchdog/Config.in b/package/watchdog/Config.in
new file mode 100644 (file)
index 0000000..bf48503
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_WATCHDOG
+       bool "watchdog"
+       depends on BR2_USE_MMU
+       help
+         Watchdog is a daemon that periodically pets a watchdog device
+         if the configured system status checks pass. If they do not,
+         the daemon may execute repair commands, shutdown the system or
+         reboot it.
+
+         https://sourceforge.net/projects/watchdog/
diff --git a/package/watchdog/watchdog.hash b/package/watchdog/watchdog.hash
new file mode 100644 (file)
index 0000000..7366c1b
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256  b8e7c070e1b72aee2663bdc13b5cc39f76c9232669cfbb1ac0adc7275a3b019d  watchdog-5.16.tar.gz
+sha256  af7f3f94e85080204b37f7c53717a2c94c6b54d7fa516ebd74e008cb4c0391bd  COPYING
diff --git a/package/watchdog/watchdog.mk b/package/watchdog/watchdog.mk
new file mode 100644 (file)
index 0000000..b814fdc
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# watchdog
+#
+################################################################################
+
+WATCHDOG_VERSION = 5.16
+WATCHDOG_SITE = http://downloads.sourceforge.net/sourceforge/watchdog
+WATCHDOG_AUTORECONF = YES
+WATCHDOG_LICENSE = GPL-2.0+
+WATCHDOG_LICENSE_FILES = COPYING
+# By default installs binaries in /usr/sbin/, but we want them in
+# /sbin/ so that they fall at the same place as Busybox counterparts
+WATCHDOG_CONF_OPTS = --sbindir=/sbin
+
+$(eval $(autotools-package))