package/qt5base: XCB support needs xcb-util-renderutil
authorPeter Seiderer <ps.report@gmx.net>
Sun, 27 Sep 2020 21:20:00 +0000 (23:20 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 30 Sep 2020 20:23:20 +0000 (22:23 +0200)
The qt5base feature 'xcb_syslibs' is a compile check
using a xcb_render_util call (see qt5base-5.15.1/src/gui/configure.json).

Fixes:
  - http://autobuild.buildroot.net/results/3c05e597c073b823f8b091e17b676ed3ecf6b5b3

  ERROR: Feature 'xcb' was enabled, but the pre-condition 'features.thread && libs.xcb && tests.xcb_syslibs && features.xkbcommon-x11' failed.

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/qt5/qt5base/Config.in
package/qt5/qt5base/qt5base.mk

index 28b03f543897e4c0d4779b16c8d060683d27daab..ce7230c72898cde92f8a3e830bfa65db1f87aff4 100644 (file)
@@ -192,6 +192,7 @@ config BR2_PACKAGE_QT5BASE_XCB
        select BR2_PACKAGE_LIBXCB
        select BR2_PACKAGE_XCB_UTIL_IMAGE
        select BR2_PACKAGE_XCB_UTIL_KEYSYMS
+       select BR2_PACKAGE_XCB_UTIL_RENDERUTIL
        select BR2_PACKAGE_XCB_UTIL_WM
        select BR2_PACKAGE_LIBXKBCOMMON
 
index 1232a037787912a5f9019da809841c6959adffad..e0189599a76eac6c0876176072b0a344c8f7f460 100644 (file)
@@ -177,6 +177,7 @@ QT5BASE_DEPENDENCIES   += \
        xcb-util-wm \
        xcb-util-image \
        xcb-util-keysyms \
+       xcb-util-renderutil \
        xlib_libX11 \
        libxkbcommon
 ifeq ($(BR2_PACKAGE_QT5BASE_WIDGETS),y)