zeromq: unbreak pgm support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 8 Mar 2016 19:43:53 +0000 (16:43 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 8 Mar 2016 20:00:33 +0000 (21:00 +0100)
In the bump to the 4.1.x series the bundled pgm library was dropped and
the --with-system-pgm option was made pointless since using unbundled
became the only option, so it was renamed to --with-pgm, which
previously meant "use bundled" (but not any longer).
However this wasn't accounted for and pgm support has been broken since
then.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/zeromq/zeromq.mk

index ce01e50f62859cf35fb55079d6d2cbac62632f6a..b80f8e49a3f24a1463e5cf297173ae60c08c6cba 100644 (file)
@@ -30,7 +30,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_ZEROMQ_PGM),y)
 ZEROMQ_DEPENDENCIES += host-pkgconf openpgm
-ZEROMQ_CONF_OPTS += --with-system-pgm
+ZEROMQ_CONF_OPTS += --with-pgm
 endif
 
 # ZeroMQ uses libsodium if it's available.