mesa3d: use positive logic for XA enabling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 2 Feb 2015 20:41:21 +0000 (21:41 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 2 Feb 2015 20:41:21 +0000 (21:41 +0100)
Thanks to commit 2dde40081c49852bac0ee9c723911761bd5fc91e
("package/mesa3d: Refactor XA support to prepare support for ATI
drivers"), we now have the blind option BR2_PACKAGE_MESA3D_NEEDS_XA
that indicates whether XA support is needed. This allows to switch to
use positive logic in the test for XA in mesa3d.mk, which this commit
does.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/mesa3d.mk

index 4ff7e094c5dcbba0f01f0e87ae69b4f3c86b34d2..de647a6e5d00eef797d4fce3d1287b635a78bb60 100644 (file)
@@ -36,7 +36,7 @@ MESA3D_DEPENDENCIES += \
        libxcb
 MESA3D_CONF_OPTS += --enable-glx
 # quote from mesa3d configure "Building xa requires at least one non swrast gallium driver."
-ifneq ($(BR2_PACKAGE_MESA3D_NEEDS_XA),)
+ifeq ($(BR2_PACKAGE_MESA3D_NEEDS_XA),y)
 MESA3D_CONF_OPTS += --enable-xa
 else
 MESA3D_CONF_OPTS += --disable-xa