perl-try-tiny: new package
authorFrancois Perrad <fperrad@gmail.com>
Tue, 22 Jul 2014 18:17:56 +0000 (20:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 23 Jul 2014 19:47:40 +0000 (21:47 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-try-tiny/Config.in [new file with mode: 0644]
package/perl-try-tiny/perl-try-tiny.mk [new file with mode: 0644]

index 40d8ba931a79f1bdc36318f9f2167edd76229c45..7c9f3ad549deb75cb0f6c425bedfd5b4ba464a39 100644 (file)
@@ -440,6 +440,7 @@ menu "Perl libraries/modules"
        source "package/perl-mojolicious/Config.in"
        source "package/perl-net-ssleay/Config.in"
        source "package/perl-path-tiny/Config.in"
+       source "package/perl-try-tiny/Config.in"
        source "package/perl-xml-libxml/Config.in"
        source "package/perl-xml-namespacesupport/Config.in"
        source "package/perl-xml-sax-base/Config.in"
diff --git a/package/perl-try-tiny/Config.in b/package/perl-try-tiny/Config.in
new file mode 100644 (file)
index 0000000..7bd5396
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PERL_TRY_TINY
+       bool "perl-try-tiny"
+       help
+         minimal try/catch with proper preservation of $@
+
+         http://metacpan.org/release/Try-Tiny
diff --git a/package/perl-try-tiny/perl-try-tiny.mk b/package/perl-try-tiny/perl-try-tiny.mk
new file mode 100644 (file)
index 0000000..0bb3d00
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-try-tiny
+#
+################################################################################
+
+PERL_TRY_TINY_VERSION = 0.22
+PERL_TRY_TINY_SOURCE = Try-Tiny-$(PERL_TRY_TINY_VERSION).tar.gz
+PERL_TRY_TINY_SITE = $(BR2_CPAN_MIRROR)/authors/id/D/DO/DOY/
+PERL_TRY_TINY_DEPENDENCIES = perl
+PERL_TRY_TINY_LICENSE = MIT
+PERL_TRY_TINY_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))