package/llvm: remove outdated variables disabling bindings
authorJoseph Kogut <joseph.kogut@gmail.com>
Mon, 16 Mar 2020 20:01:06 +0000 (13:01 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 18 Mar 2020 21:46:56 +0000 (22:46 +0100)
LLVM no longer disables unsupported bindings by overriding OCAMLFIND and
GO_EXECUTABLE, so remove them.

Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/llvm/llvm.mk

index f1034f0365625d6f3d1280094f2da3abf8c3238f..24d033d1244701721b806832f754dfa15009e88b 100644 (file)
@@ -189,11 +189,8 @@ LLVM_CONF_OPTS += -DLLVM_DEFAULT_TARGET_TRIPLE=$(GNU_TARGET_NAME)
 # This solves "No available targets are compatible for this triple" with llvmpipe
 LLVM_CONF_OPTS += -DLLVM_HOST_TRIPLE=$(GNU_TARGET_NAME)
 
-# The Go bindings have no CMake rules at the moment, but better remove the
-# check preventively. Building the Go and OCaml bindings is yet unsupported.
+# Building the Go and OCaml bindings is yet unsupported.
 HOST_LLVM_CONF_OPTS += \
-       -DGO_EXECUTABLE=GO_EXECUTABLE-NOTFOUND \
-       -DOCAMLFIND=OCAMLFIND-NOTFOUND \
        -DLLVM_ENABLE_BINDINGS=OFF
 
 # Builds a release host tablegen that gets used during the LLVM build.