dropbear: fix xauth tweak since dbcec2b2
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 28 Sep 2010 07:22:19 +0000 (09:22 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 28 Sep 2010 07:22:19 +0000 (09:22 +0200)
The recent conversion to new-style hooks didn't actually enable the
xauth tweaking. Also rename to FIX_XAUTH as it just tweaks the path,
it doesn't disable anything.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/dropbear/dropbear.mk

index 0b0d4c7322ae0779918ffe0c3748f6466f3e99f2..0457935b98c02a39ab3526f966cd32391aacad8d 100644 (file)
@@ -17,11 +17,11 @@ DROPBEAR_CONF_ENV = ac_cv_type_struct_sockaddr_storage=yes
 DROPBEAR_MAKE =        $(MAKE) MULTI=1 SCPPROGRESS=1 \
                PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp"
 
-define DROPBEAR_DISABLE_XAUTH
+define DROPBEAR_FIX_XAUTH
        $(SED) 's,^#define XAUTH_COMMAND.*/xauth,#define XAUTH_COMMAND "/usr/bin/xauth,g' $(@D)/options.h
 endef
 
-DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_ADJUST_OPTIONS
+DROPBEAR_POST_EXTRACT_HOOKS += DROPBEAR_FIX_AUTH
 
 define DROPBEAR_DISABLE_REVERSE_DNS
        $(SED) 's,^#define DO_HOST_LOOKUP.*,/* #define DO_HOST_LOOKUP */,' $(@D)/options.h