opus: don't use assembly when on ARM, but without ARM instructions
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Jul 2016 19:41:47 +0000 (21:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Jul 2016 19:44:08 +0000 (21:44 +0200)
The ARM assembly code in opus uses full ARM instructions, which won't
work on Thumb-2 only platforms such as ARMv7-M, so we disable the
assembly code in such situations.

Fixes:

  http://autobuild.buildroot.net/results/ffa12ab7abadd76901228fc82da24e81bb6da625/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/opus/opus.mk

index f746a2f8287d3afc8774e3da42924a16582cde00..71fdcb3f0c690a9e7b1591b62e0ab1f21aa8780f 100644 (file)
@@ -14,4 +14,10 @@ ifeq ($(BR2_PACKAGE_OPUS_FIXED_POINT),y)
 OPUS_CONF_OPTS += --enable-fixed-point
 endif
 
+# When we're on ARM, but we don't have ARM instructions (only
+# Thumb-2), disable the usage of assembly as it is not Thumb-ready.
+ifeq ($(BR2_arm)$(BR2_armeb):$(BR2_ARM_CPU_HAS_ARM),y:)
+OPUS_CONF_OPTS += --disable-asm
+endif
+
 $(eval $(autotools-package))