Split the target suffix out as a config option, for the few cases where
authorPaul Mundt <lethal@linux-sh.org>
Mon, 5 Jun 2006 21:49:44 +0000 (21:49 -0000)
committerPaul Mundt <lethal@linux-sh.org>
Mon, 5 Jun 2006 21:49:44 +0000 (21:49 -0000)
we have to use a different one.

Config.in
package/Makefile.in

index 41761f5e79ff53476c722222207195f71cb5bfd0..04b46dac7d273e9d2310c070ecdc404c93ef7ec4 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -236,6 +236,18 @@ config BR2_GNU_BUILD_SUFFIX
              cygwin:  pc-cygwin
              os x:    apple-darwin7 / apple-darwin8
 
+config BR2_GNU_TARGET_SUFFIX
+       string "GNU target suffix"
+       default "linux-uclibc"
+       help
+           The string used to pass to configure scripts via the
+           --target= option.  Just specify the suffix here, the leading
+           arch will be filled in automatically.
+
+           Most users will want to stick with the default setting, though
+           other users (most notably ARM EABI) like to add on to this in
+           order to stay in line with gcc conventions.
+
 config BR2_JLEVEL
        int "Number of jobs to run simultaneously"
        default "1"
index 6f3cbb71f0c8540c9c3d1e37dc2c996a6e316efb..595d8625dbb863e7b9d27f78fa048d13a19853fc 100644 (file)
@@ -38,15 +38,16 @@ BUILD_DIR:=$(BASE_DIR)/$(TOPDIR_PREFIX)build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_S
 TARGET_DIR:=$(BUILD_DIR)/root
 TOOL_BUILD_DIR=$(BASE_DIR)/$(TOPDIR_PREFIX)toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)$(TOPDIR_SUFFIX)
 
+GNU_TARGET_SUFFIX:=-$(strip $(subst ",, $(BR2_GNU_TARGET_SUFFIX)))
 # Strip off the annoying quoting
 STAGING_DIR:=$(strip $(subst ",, $(BR2_STAGING_DIR)))
 #"
 TARGET_PATH=$(STAGING_DIR)/bin:$(TOOL_BUILD_DIR)/bin:/bin:/sbin:/usr/bin:/usr/sbin
 IMAGE:=$(BASE_DIR)/rootfs.$(ARCH)$(ARCH_FPU_SUFFIX)
-REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux-uclibc
+REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)$(GNU_TARGET_SUFFIX)
 GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux
-KERNEL_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)-linux-uclibc-
-TARGET_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)-linux-uclibc-
+KERNEL_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)$(GNU_TARGET_SUFFIX)-
+TARGET_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)$(GNU_TARGET_SUFFIX)-
 TARGET_CC=$(TARGET_CROSS)gcc
 TARGET_CXX=$(TARGET_CROSS)g++
 TARGET_RANLIB=$(TARGET_CROSS)ranlib