pkg-download.mk: use stripurischeme function in localfiles download method
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>
Fri, 22 Jun 2012 05:42:35 +0000 (07:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Jul 2012 14:53:24 +0000 (16:53 +0200)
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-download.mk

index fb515407657aaa3146cbafb757ab21569a28e9ee..ca5b40466a26ce38172f5822f32db0957fc120f0 100644 (file)
@@ -178,11 +178,11 @@ endef
 
 define DOWNLOAD_LOCALFILES
        test -e $(DL_DIR)/$(2) || \
-               $(LOCALFILES) $(call qstrip,$(subst file://,,$(1))) $(DL_DIR)
+               $(LOCALFILES) $(call stripurischeme,$(call qstrip,$(1))) $(DL_DIR)
 endef
 
 define SOURCE_CHECK_LOCALFILES
-  test -e $(call qstrip,$(subst file://,,$(1)))
+  test -e $(call stripurischeme,$(call qstrip,$(1)))
 endef
 
 define SHOW_EXTERNAL_DEPS_LOCALFILES