tinyhttpd: fix initscript, install as /usr/sbin/tinyhttpd
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 3 Apr 2012 20:51:05 +0000 (22:51 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 3 Apr 2012 20:51:05 +0000 (22:51 +0200)
The init script was expecting the binary to be called tinyhttpd, but httpd
was used. Fix it to install as tinyhttpd as httpd will conflict with other
web servers (E.G. the busybox one).

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/tinyhttpd/tinyhttpd.mk

index 6bc37d46e3d753b5e38a52d4a3f4cca8be00cb8c..9b06589d3c214421dec2c82cd307282b3ad2d18b 100644 (file)
@@ -12,14 +12,14 @@ define TINYHTTPD_BUILD_CMDS
 endef
 
 define TINYHTTPD_INSTALL_TARGET_CMDS
-       $(INSTALL) -m 0755 -D $(@D)/httpd $(TARGET_DIR)/usr/sbin/httpd
+       $(INSTALL) -m 0755 -D $(@D)/httpd $(TARGET_DIR)/usr/sbin/tinyhttpd
        $(INSTALL) -m 0755 -D package/tinyhttpd/S85tinyhttpd \
                $(TARGET_DIR)/etc/init.d/S85tinyhttpd
        mkdir -p $(TARGET_DIR)/var/www
 endef
 
 define TINYHTTPD_CLEAN_CMDS
-       rm -f $(TARGET_DIR)/usr/sbin/httpd
+       rm -f $(TARGET_DIR)/usr/sbin/tinyhttpd
        rm -f $(TARGET_DIR)/etc/init.d/S85tinyhttpd
 endef