Makefile: don't export GZIP environment variable
authorAtharva Lele <itsatharva@gmail.com>
Tue, 16 Jul 2019 17:42:14 +0000 (23:12 +0530)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 17 Jul 2019 06:46:05 +0000 (08:46 +0200)
We export GZIP = -n so that GZIP does not record original
name and timestamps. However..

GZIP environment variable is deprecated and soon will not be
supported in future GZIP versions. GZIP suggests the use of a
wrapper to pass options globally but it might be difficult to
implement in Buildroot. For now, we don't export the variable
and fix reproducibility issues per package as they show up in
Autobuilder.

Signed-off-by: Atharva Lele <itsatharva@gmail.com>
Acked-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Makefile

index c98a0ed87eae20f88a03edd10ae981f00707e245..9cce9349904d5b7331f0590d53de3953afd2de23 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -248,7 +248,6 @@ ifeq ($(BR2_REPRODUCIBLE),y)
 export TZ = UTC
 export LANG = C
 export LC_ALL = C
-export GZIP = -n
 endif
 
 # To put more focus on warnings, be less verbose as default