gpm: fix build on Microblaze due to ELF check
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 May 2014 09:50:21 +0000 (11:50 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 17 May 2014 11:20:31 +0000 (13:20 +0200)
Fixes:

  http://autobuild.buildroot.org/results/19d/19d93324caac8b4aad7abfe7b6c3d85612636368/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gpm/gpm.mk

index 477c54a55e924b7204617828b0651b8ada66fdf6..d37b4edcc3953db1684fcb61d88822b4fad1dca8 100644 (file)
@@ -17,6 +17,14 @@ GPM_DEPENDENCIES = host-bison
 # built. CPPFLAGS is used to pass the right include path to dependency rules.
 GPM_CONF_ENV = CPPFLAGS="$(TARGET_CPPFLAGS) -I$(@D)/src/headers/"
 
+# For some reason, Microblaze gcc does not define __ELF__, which gpm
+# configure script uses to determine whether the architecture uses ELF
+# binaries and therefore can build shared libraries. We fix this by
+# telling GPM that ELF is used on Microblaze.
+ifeq ($(BR2_microblaze),y)
+GPM_CONF_ENV += itz_cv_sys_elf=yes
+endif
+
 # gpm and ncurses have a circular dependency. As gpm function GPM_Wgetch()
 # (requiring ncurses) is not recommended for use by ncurses people themselves
 # and as it's better to have gpm support in ncurses that the contrary, we force