squashfs: fix build when zlib isn't available on the host
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 7 May 2010 19:22:00 +0000 (21:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 7 May 2010 19:32:02 +0000 (21:32 +0200)
Pass CFLAGS and LDFLAGS so that when building squashfs, it finds the
zlib installed in $(HOST_DIR).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/squashfs/squashfs.mk

index ab05b06e5e34a0dd87892ba2bf77c411dd681803..1dccb0881bb5e902c11bdc7bdbecccbe0b6d7dc2 100644 (file)
@@ -18,7 +18,7 @@ define SQUASHFS_INSTALL_TARGET_CMDS
 endef
 
 define HOST_SQUASHFS_BUILD_CMDS
- $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/squashfs-tools/
+ $(HOST_MAKE_ENV) $(MAKE) CFLAGS="$(HOST_CFLAGS)" LDFLAGS="$(HOST_LDFLAGS)" -C $(@D)/squashfs-tools/
 endef
 
 define HOST_SQUASHFS_INSTALL_CMDS