musepack: disable parallel build
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 12 Sep 2011 11:57:14 +0000 (13:57 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 12 Sep 2011 11:57:14 +0000 (13:57 +0200)
The musepack build system contains a race condition, which gets triggered by
high BR2_JLEVEL settings - It tries to link against libmpcdec before it is
created:

Linking C executable mpcgain
/scratch/peko/host/usr/lib/gcc/arm-unknown-linux-uclibcgnueabi/4.4.6/../../../../arm-unknown-linux-uclibcgnueabi/bin/ld: cannot find -lmpcdec
collect2: ld returned 1 exit status
make[3]: *** [mpcgain/mpcgain] Error 1

Fix it by disabling parallel build.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/musepack/musepack.mk

index 21601ebcba63e8840a13273c2044ced1b7a9e68b..1e5ebcfe841176529a33c722ba8f3b8601f80825 100644 (file)
@@ -9,5 +9,6 @@ MUSEPACK_SITE = http://files.musepack.net/source
 MUSEPACK_SOURCE = musepack_src_$(MUSEPACK_VERSION).tar.gz
 MUSEPACK_DEPENDENCIES = libcuefile libreplaygain
 MUSEPACK_INSTALL_STAGING = YES
+MUSEPACK_MAKE = $(MAKE1)
 
 $(eval $(call CMAKETARGETS,package/multimedia,musepack))