pkg-config: bump version
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 29 Jan 2011 21:06:28 +0000 (22:06 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 29 Jan 2011 21:06:28 +0000 (22:06 +0100)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pkg-config/pkg-config-0.23-fix-sysroot.patch [deleted file]
package/pkg-config/pkg-config.mk

diff --git a/package/pkg-config/pkg-config-0.23-fix-sysroot.patch b/package/pkg-config/pkg-config-0.23-fix-sysroot.patch
deleted file mode 100644 (file)
index 3653811..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-[PATCH] fix PKG_CONFIG_SYSROOT_DIR handling
-
-With PKG_CONFIG_SYSROOT_DIR enabled, everything else than -L and -I words
-gets stripped away.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- pkg.c |    8 ++------
- 1 file changed, 2 insertions(+), 6 deletions(-)
-
-Index: pkg-config-0.23/pkg.c
-===================================================================
---- pkg-config-0.23.orig/pkg.c
-+++ pkg-config-0.23/pkg.c
-@@ -472,17 +472,13 @@
-   while (tmp != NULL)
-     {
-       char *tmpstr = (char*) tmp->data;
--      if (pcsysrootdir != NULL)
-+      if (pcsysrootdir != NULL && tmpstr[0] == '-' &&
-+          (tmpstr[1] == 'I' || tmpstr[1] == 'L'))
-       {
--        if (tmpstr[0] == '-' &&
--            (tmpstr[1] == 'I' ||
--             tmpstr[1] == 'L'))
--          {
-             g_string_append_c (str, '-');
-             g_string_append_c (str, tmpstr[1]);
-             g_string_append (str, pcsysrootdir);
-             g_string_append (str, tmpstr+2);
--          }
-       }
-       else 
-       {
index d0bc424789789ed0456cb8707875709ed1d4c42c..413853d974edc824ce1942d07161509a42a26d17 100644 (file)
@@ -3,7 +3,7 @@
 # pkgconfig
 #
 #############################################################
-PKG_CONFIG_VERSION = 0.23
+PKG_CONFIG_VERSION = 0.25
 PKG_CONFIG_SOURCE = pkg-config-$(PKG_CONFIG_VERSION).tar.gz
 PKG_CONFIG_SITE = http://pkgconfig.freedesktop.org/releases/