cutelyst: new package
authorDaniel Nicoletti <dantti12@gmail.com>
Tue, 17 Jul 2018 20:46:13 +0000 (17:46 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 18 Jul 2018 10:55:41 +0000 (12:55 +0200)
A C++ Web Framework built on top of Qt, using
the simple approach of Catalyst (Perl) framework.

Signed-off-by: Daniel Nicoletti <dantti12@gmail.com>
[Thomas: add entry in DEVELOPERS file, move cmake-package invocation
to the end of .mk file, select BR2_PACKAGE_OPENSSL.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/cutelyst/Config.in [new file with mode: 0644]
package/cutelyst/cutelyst.hash [new file with mode: 0644]
package/cutelyst/cutelyst.mk [new file with mode: 0644]

index 25c3ebe970d481e5af84b09edcaff9d430c173d9..257f6ff89e9d18f3d3aabf79369a68a8174d5a14 100644 (file)
@@ -510,6 +510,9 @@ N:  Damien Lanson <damien@kal-host.com>
 F:     package/libvdpau/
 F:     package/log4cpp/
 
+N:     Daniel Nicoletti <dantti12@gmail.com>
+F:     package/cutelyst/
+
 N:     Daniel Nyström <daniel.nystrom@timeterminal.se>
 F:     package/e2tools/
 
index eedce83616648da89650cda7e482f13dc91ff7fd..08a3eac48ad0d08f2f00f3d01f019c04f458917f 100644 (file)
@@ -314,6 +314,7 @@ comment "Other GUIs"
        source "package/kf5/Config.in"
 if BR2_PACKAGE_QT || BR2_PACKAGE_QT5
 comment "QT libraries and helper libraries"
+       source "package/cutelyst/Config.in"
        source "package/grantlee/Config.in"
        source "package/qextserialport/Config.in"
        source "package/qjson/Config.in"
diff --git a/package/cutelyst/Config.in b/package/cutelyst/Config.in
new file mode 100644 (file)
index 0000000..5a3974a
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_CUTELYST
+       bool "cutelyst"
+       depends on BR2_PACKAGE_QT5
+       select BR2_PACKAGE_OPENSSL
+       select BR2_PACKAGE_QT5BASE_GUI
+       help
+         A C++ Web Framework built on top of Qt, using
+         the simple approach of Catalyst (Perl) framework.
+
+         https://cutelyst.org
diff --git a/package/cutelyst/cutelyst.hash b/package/cutelyst/cutelyst.hash
new file mode 100644 (file)
index 0000000..58645e5
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated after checking pgp signature
+sha256  a5d40c5e0027982181529449ffa807492f5759c2c604cdc467e748445721ff28    cutelyst-2.5.1.tar.gz
+sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551    COPYING
diff --git a/package/cutelyst/cutelyst.mk b/package/cutelyst/cutelyst.mk
new file mode 100644 (file)
index 0000000..438ac09
--- /dev/null
@@ -0,0 +1,36 @@
+################################################################################
+#
+# cutelyst
+#
+################################################################################
+
+CUTELYST_VERSION = 2.5.1
+CUTELYST_SITE = https://github.com/cutelyst/cutelyst/archive/v$(CUTELYST_VERSION)
+CUTELYST_INSTALL_STAGING = YES
+CUTELYST_SUPPORTS_IN_SOURCE_BUILD = NO
+CUTELYST_LICENSE = LGPL-2.1+
+CUTELYST_LICENSE_FILES = COPYING
+CUTELYST_DEPENDENCIES = qt5base
+
+CUTELYST_CONF_OPTS += \
+       -DPLUGIN_CSRFPROTECTION=ON
+
+ifeq ($(BR2_PACKAGE_GRANTLEE),y)
+CUTELYST_CONF_OPTS += -DPLUGIN_VIEW_GRANTLEE=ON
+else
+CUTELYST_CONF_OPTS += -DPLUGIN_VIEW_GRANTLEE=OFF
+endif
+
+ifeq ($(BR2_PACKAGE_LIBPWQUALITY),y)
+CUTELYST_CONF_OPTS += -DPLUGIN_VALIDATOR_PWQUALITY=ON
+else
+CUTELYST_CONF_OPTS += -DPLUGIN_VALIDATOR_PWQUALITY=OFF
+endif
+
+ifeq ($(BR2_PACKAGE_JEMALLOC),y)
+CUTELYST_CONF_OPTS += -DUSE_JEMALLOC=ON
+else
+CUTELYST_CONF_OPTS += -DUSE_JEMALLOC=OFF
+endif
+
+$(eval $(cmake-package))