package/ghostscript: fix removal of included lcms2
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 1 Oct 2018 16:34:19 +0000 (18:34 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 3 Oct 2018 07:38:34 +0000 (09:38 +0200)
Ghostscript 9.24 changed the internal lcms2 version:
https://www.ghostscript.com/doc/9.24/News.htm

With this change the directory name was also changed which broke our
code to force the usage of the buildroot lcms2 package.

Fixes
http://autobuild.buildroot.net/results/d04/d04ad017bf06a442a7397f935959994ba72824e1/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ghostscript/ghostscript.mk

index 9b5e1448888079bbb470bbe7d32b9d99bafc91fc..b1f5e1edb1240f1e4bb6c4fb28b15fe888cbf70d 100644 (file)
@@ -27,8 +27,8 @@ GHOSTSCRIPT_DEPENDENCIES = \
 # Inspired by linuxfromscratch:
 # http://www.linuxfromscratch.org/blfs/view/svn/pst/gs.html
 define GHOSTSCRIPT_REMOVE_LIBS
-       rm -rf $(@D)/freetype $(@D)/ijs $(@D)/jpeg $(@D)/lcms2 \
-               $(@D)/lcms2art $(@D)/libpng $(@D)/tiff $(@D)/zlib
+       rm -rf $(@D)/freetype $(@D)/ijs $(@D)/jpeg $(@D)/lcms2mt \
+               $(@D)/libpng $(@D)/tiff $(@D)/zlib
 endef
 GHOSTSCRIPT_POST_PATCH_HOOKS += GHOSTSCRIPT_REMOVE_LIBS