package/ncmpc: bump to version 0.37
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 3 Feb 2020 18:26:18 +0000 (19:26 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Feb 2020 20:17:54 +0000 (21:17 +0100)
Bump gcc requirement to gcc >= 7 as C++17 is mandatory since
https://github.com/MusicPlayerDaemon/ncmpc/commit/85f136dd6b6a8d044b19cbef818ee360292cc06e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ncmpc/Config.in
package/ncmpc/ncmpc.hash
package/ncmpc/ncmpc.mk

index 2122bf354342a921172433ec9be1255e24c3a2d6..0e062460a715850a24b543534e288383f08bc0ce 100644 (file)
@@ -4,7 +4,7 @@ config BR2_PACKAGE_NCMPC
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_WCHAR # boost
        depends on BR2_TOOLCHAIN_HAS_THREADS # boost
-       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_6 # C++14
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_7 # C++17
        select BR2_PACKAGE_BOOST
        select BR2_PACKAGE_BOOST_SYSTEM
        select BR2_PACKAGE_LIBMPDCLIENT
@@ -16,7 +16,7 @@ config BR2_PACKAGE_NCMPC
 
          http://www.musicpd.org/clients/ncmpc/
 
-comment "ncmpc needs a toolchain w/ C++, wchar, threads, gcc >= 6"
+comment "ncmpc needs a toolchain w/ C++, wchar, threads, gcc >= 7"
        depends on BR2_USE_MMU
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
-               !BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_GCC_AT_LEAST_6
+               !BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_GCC_AT_LEAST_7
index 2a8533a2ee0f5b40d517afadb09b9518ed1cb200..963c6d260104bf95ebcacf431799ced5a8ae6b44 100644 (file)
@@ -1,5 +1,5 @@
 # Locally calculated after checking pgp signature
-sha256 4632873dfc8efe61e501dc9184a5b921b482be2ddbedd3d23d05241d477a3e2c  ncmpc-0.36.tar.xz
+sha256 7c8eb727f6e12d8f97a53915b1b5632898b4afb335a1121c5e01c81df695615c  ncmpc-0.37.tar.xz
 
 # Hash for license file:
 sha256 ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6  COPYING
index 86e3c8383fbdebeaa8f3c9f3b8ff7ac010dd843e..29675f225693d5ce500134c6fbcf40ba402873d4 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 NCMPC_VERSION_MAJOR = 0
-NCMPC_VERSION = $(NCMPC_VERSION_MAJOR).36
+NCMPC_VERSION = $(NCMPC_VERSION_MAJOR).37
 NCMPC_SOURCE = ncmpc-$(NCMPC_VERSION).tar.xz
 NCMPC_SITE = http://www.musicpd.org/download/ncmpc/$(NCMPC_VERSION_MAJOR)
 NCMPC_DEPENDENCIES = \