package/ffmpeg: bump version to 4.3
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 20 Jun 2020 21:34:01 +0000 (23:34 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 21 Jun 2020 07:32:48 +0000 (09:32 +0200)
Add a patch to fix build without ssse3.

Update the license hash due to various changes since August 2019 [0]:

  - some files were relicensed from GPL-2.0+ to LGPL-2.1+; no impact on
    the licensing information;

  - clarification about the licensing when linked with external
    libraries, which now requires passing --enable-version3; Buildroot
    is not concerned, because it passes --disable-version3;

  - various clarification about applicable licensing terms.

[0] http://git.videolan.org/?p=ffmpeg.git;a=history;f=LICENSE.md;h=613070e1b631a919a74c862f2a75a0f249a631ff;hb=8e12af29d1a3f95c9e952d78354e3c8b1c0431a8

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[yann.morin.1998@free.fr:
  - fix the SoB order in the patch
  - clarify the impact of the licensing changes
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/ffmpeg/0001-swscale-x86-yuv2rgb-Fix-build-without-SSSE3.patch [new file with mode: 0644]
package/ffmpeg/ffmpeg.hash
package/ffmpeg/ffmpeg.mk

diff --git a/package/ffmpeg/0001-swscale-x86-yuv2rgb-Fix-build-without-SSSE3.patch b/package/ffmpeg/0001-swscale-x86-yuv2rgb-Fix-build-without-SSSE3.patch
new file mode 100644 (file)
index 0000000..951ce41
--- /dev/null
@@ -0,0 +1,43 @@
+From bf8eae2d30a205bb76ac625e04c0351106981b9e Mon Sep 17 00:00:00 2001
+From: Parker Ernest <@>
+Date: Sun, 23 Feb 2020 13:22:42 +0100
+Subject: [PATCH] swscale/x86/yuv2rgb: Fix build without SSSE3
+
+commit fc6a5883d6af8cae0e96af84dda0ad74b360a084 breaks build on
+x86_64 CPUs which do not have SSSE3, e.g. AMD Phenom-II
+
+Signed-off-by: Michael Niedermayer <michael@niedermayer.cc>
+[bernd.kuhls@t-online.de:
+  - retrieved from upstream patchwork:
+    https://patchwork.ffmpeg.org/project/ffmpeg/patch/20200223122256.23402-1-michael@niedermayer.cc/
+]
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+[yann.morin.1998@free.fr: fix reference top patchwork and SoB order]
+Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
+---
+ libswscale/x86/yuv2rgb.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/libswscale/x86/yuv2rgb.c b/libswscale/x86/yuv2rgb.c
+index c12e88cbb5..4791e5b93a 100644
+--- a/libswscale/x86/yuv2rgb.c
++++ b/libswscale/x86/yuv2rgb.c
+@@ -83,6 +83,7 @@ av_cold SwsFunc ff_yuv2rgb_init_x86(SwsContext *c)
+ #if HAVE_X86ASM
+     int cpu_flags = av_get_cpu_flags();
++#if HAVE_SSSE3
+     if (EXTERNAL_SSSE3(cpu_flags)) {
+         switch (c->dstFormat) {
+         case AV_PIX_FMT_RGB32:
+@@ -111,6 +112,7 @@ av_cold SwsFunc ff_yuv2rgb_init_x86(SwsContext *c)
+             return yuv420_rgb15_ssse3;
+         }
+     }
++#endif
+     if (EXTERNAL_MMXEXT(cpu_flags)) {
+         switch (c->dstFormat) {
+-- 
+2.26.2
+
index 35bd6813268a16928c4b0406656f89ba503287dd..1572285cd6f63fee63abb357cf2ed8eedfe1180d 100644 (file)
@@ -1,5 +1,5 @@
 # Locally calculated
-sha256  9df6c90aed1337634c1fb026fb01c154c29c82a64ea71291ff2da9aacb9aad31  ffmpeg-4.2.3.tar.xz
+sha256  1d0ad06484f44bcb97eba5e93c40bcb893890f9f64aeb43e46cd9bb4cbd6795d  ffmpeg-4.3.tar.xz
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  COPYING.GPLv2
 sha256  b634ab5640e258563c536e658cad87080553df6f34f62269a21d554844e58bfe  COPYING.LGPLv2.1
-sha256  cad1218c22121b169fb1380178ab7a0b33cb38a3ff6d3915b8533d1d954f3ce7  LICENSE.md
+sha256  cb48bf09a11f5fb576cddb0431c8f5ed0a60157a9ec942adffc13907cbe083f2  LICENSE.md
index 736aa5b4baca3f3624c38d36c08890855d883864..aeebc0effc90f8162fe66c4efb19320403434cae 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-FFMPEG_VERSION = 4.2.3
+FFMPEG_VERSION = 4.3
 FFMPEG_SOURCE = ffmpeg-$(FFMPEG_VERSION).tar.xz
 FFMPEG_SITE = http://ffmpeg.org/releases
 FFMPEG_INSTALL_STAGING = YES