core/pkg-generic: redirect only when listing package's installed files
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 28 Oct 2017 15:30:57 +0000 (17:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Nov 2017 21:56:55 +0000 (22:56 +0100)
There is no need to redirect again and again for each new file added to
the list; we can just redirect once and for all.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index d4cb42d8923669729872c89ba7b3b6e23e6dff65..ad10a8c9033d92306e510c3bc4e4f198dde9bd7e 100644 (file)
@@ -83,8 +83,8 @@ define step_pkg_size_end
        $(call _step_pkg_size_get_file_list,$($(PKG)_DIR)/.br_filelist_after)
        comm -13 $($(PKG)_DIR)/.br_filelist_before $($(PKG)_DIR)/.br_filelist_after | \
                while read hash file ; do \
-                       echo "$(1),$${file}" >> $(BUILD_DIR)/packages-file-list.txt ; \
-               done
+                       echo "$(1),$${file}" ; \
+               done >> $(BUILD_DIR)/packages-file-list.txt
        rm -f $($(PKG)_DIR)/.br_filelist_before $($(PKG)_DIR)/.br_filelist_after
 endef