buildroot: reinstate /etc/{hostname,issue} kconfig when using generic target
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 30 Sep 2009 19:53:22 +0000 (21:53 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 30 Sep 2009 19:53:22 +0000 (21:53 +0200)
These got lost in the recent cleanup, but are handy for minimal rootfs
customization.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
target/generic/Config.in
target/generic/Makefile.in

index 5de581104c143eb7871d5d91fee40b3f7254c8ae..b70874a4e3249d777fd54636a445d80848e64b2a 100644 (file)
@@ -61,9 +61,22 @@ config BR2_TARGET_GENERIC_DEV_SYSTEM
 comment "Generic development system requires a toolchain with WCHAR and PROGRAM_INVOCATION support"
        depends on !(BR2_USE_WCHAR && BR2_PROGRAM_INVOCATION)
 
+if !(BR2_TARGET_ATMEL||BR2_TARGET_KWIKBYTE||BR2_TARGET_VALKA)
+
+config BR2_TARGET_GENERIC_HOSTNAME
+       string "System hostname"
+       default "buildroot"
+       help
+         Select system hostname to be stored in /etc/hostname.
+
+config BR2_TARGET_GENERIC_ISSUE
+       string "System banner"
+       default "Welcome to Buildroot"
+       help
+         Select system banner (/etc/issue) to be displayed at login.
+
 menuconfig BR2_TARGET_GENERIC_GETTY
        bool "Generic serial port config"
-       depends on !(BR2_TARGET_ATMEL||BR2_TARGET_KWIKBYTE||BR2_TARGET_VALKA)
 
 if BR2_TARGET_GENERIC_GETTY
 
@@ -214,4 +227,6 @@ config BR2_TARGET_GENERIC_GETTY_BAUDRATE
        default "57600"         if BR2_TARGET_GENERIC_GETTY_BAUDRATE_57600
        default "115200"        if BR2_TARGET_GENERIC_GETTY_BAUDRATE_115200
 
+endif # BR2_TARGET_GENERIC_GETTY
+
 endif
index 084acf48b0c3ae3e364e5b21fec9424a5ce1406c..31f4a0c3b7efae8210381e2de12a3491c3c46d2f 100644 (file)
@@ -10,10 +10,26 @@ endif
 TARGET_GENERIC_GETTY:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT))
 TARGET_GENERIC_GETTY_BAUDRATE:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_BAUDRATE))
 
+target-generic-hostname:
+       mkdir -p $(TARGET_DIR)/etc
+       echo "$(TARGET_GENERIC_HOSTNAME)" > $(TARGET_DIR)/etc/hostname
+
+target-generic-issue:
+       mkdir -p $(TARGET_DIR)/etc
+       echo "$(TARGET_GENERIC_ISSUE)" > $(TARGET_DIR)/etc/issue
+
 target-generic-getty:
        $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(TARGET_GENERIC_GETTY)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
                $(TARGET_DIR)/etc/inittab
 
+ifneq ($(BR2_TARGET_GENERIC_HOSTNAME),)
+TARGETS += target-generic-hostname
+endif
+
+ifneq ($(BR2_TARGET_GENERIC_ISSUE),)
+TARGETS += target-generic-issue
+endif
+
 ifeq ($(BR2_TARGET_GENERIC_GETTY),y)
 TARGETS += target-generic-getty
 endif