libecore: tweak makekeys workaround for make 3.82
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 15 Feb 2012 22:22:23 +0000 (23:22 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 15 Feb 2012 22:22:23 +0000 (23:22 +0100)
It seems that make 3.82 gets confused and considers makekeys
out of date when there isn't a makekeys.o, so ensure that we
create both makekeys and makekeys.o before building.

Also move the workaround to the extract step so we can build using
make's default rules rather than explicitly calling gcc.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/libecore/libecore.mk

index 2b668ab94fb14be6ae8ac4fe437f232e64d4f13e..db14356ae6614254b84e289b34f4ebbdde4e8737 100644 (file)
@@ -76,11 +76,10 @@ LIBECORE_DEPENDENCIES += libxcb xlib_libX11 xcb-util
 # teach it about CC_FOR_BUILD, but for now simply build makekeys by
 # hand in advance
 define LIBECORE_BUILD_MAKEKEYS_FOR_HOST
-       cd $(@D)/src/util && $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) \
-               -o makekeys makekeys.c
+       $(HOST_CONFIGURE_OPTS) $(MAKE1) -C $(@D)/src/util makekeys.o makekeys
 endef
 
-LIBECORE_POST_CONFIGURE_HOOKS += LIBECORE_BUILD_MAKEKEYS_FOR_HOST
+LIBECORE_POST_EXTRACT_HOOKS += LIBECORE_BUILD_MAKEKEYS_FOR_HOST
 else
 LIBECORE_CONF_OPT += --disable-ecore-x-xcb
 endif