Makefile: Add /usr/lib/locale to target-purgelocales
authorValentine Barshak <gvaxon@gmail.com>
Tue, 2 Oct 2012 19:03:51 +0000 (23:03 +0400)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Feb 2014 09:15:57 +0000 (10:15 +0100)
Some packages install locales to /usr/lib/locale.
Parse and purge unneeded ones there too.

Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index dc57cf440fd40d126dff136507f6377925a6cef3..4a675d443a559cd6028e0472e748e2eacef3bc37 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -564,7 +564,7 @@ target-purgelocales:
        rm -f $(LOCALE_WHITELIST)
        for i in $(LOCALE_NOPURGE); do echo $$i >> $(LOCALE_WHITELIST); done
 
-       for dir in $(wildcard $(addprefix $(TARGET_DIR),/usr/share/locale /usr/share/X11/locale /usr/man /usr/share/man)); \
+       for dir in $(wildcard $(addprefix $(TARGET_DIR),/usr/share/locale /usr/share/X11/locale /usr/man /usr/share/man /usr/lib/locale)); \
        do \
                for lang in $$(cd $$dir; ls .|grep -v man); \
                do \