znc: new package
authorCédric Chépied <cedric.chepied@gmail.com>
Fri, 4 Apr 2014 18:22:53 +0000 (20:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Apr 2014 16:39:16 +0000 (18:39 +0200)
ported patch from Cédric Chépied:
http://patchwork.ozlabs.org/patch/306896/

[Thomas: added comment explaining why we don't use <pkg>_AUTORECONF,
and use a more conventional syntax for <pkg>_DEPENDENCIES and
<pkg>_CONF_OPT.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/znc/Config.in [new file with mode: 0644]
package/znc/znc.mk [new file with mode: 0644]

index 98d94e37df55fa0336111a85564cf9597b080287..4a7fed63281f0461d06621caeadb5bf08d8b9e39 100644 (file)
@@ -1025,6 +1025,7 @@ source "package/wpa_supplicant/Config.in"
 source "package/wvdial/Config.in"
 source "package/xinetd/Config.in"
 source "package/xl2tp/Config.in"
+source "package/znc/Config.in"
 
 endmenu
 
diff --git a/package/znc/Config.in b/package/znc/Config.in
new file mode 100644 (file)
index 0000000..c055f9f
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_ZNC
+       bool "znc"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         Advanced IRC bouncer
+
+         http://www.znc.in
+
+comment "znc needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/znc/znc.mk b/package/znc/znc.mk
new file mode 100644 (file)
index 0000000..5e9b45b
--- /dev/null
@@ -0,0 +1,49 @@
+################################################################################
+#
+# znc
+#
+################################################################################
+
+ZNC_VERSION = b396cafdb249544164ed02942a5babba59e519a3
+ZNC_SITE = git://github.com/znc/znc.git
+ZNC_LICENSE = Apache-2.0
+ZNC_LICENSE_FILES = LICENSE
+ZNC_DEPENDENCIES = host-pkgconf host-autoconf host-automake
+ZNC_CONF_OPT = --disable-perl
+
+# The standard <pkg>_AUTORECONF = YES invocation doesn't work for this
+# package, because it does not use automake in a normal way.
+define ZNC_RUN_AUTOGEN
+       cd $(@D) && PATH=$(HOST_PATH) ./autogen.sh
+endef
+ZNC_PRE_CONFIGURE_HOOKS += ZNC_RUN_AUTOGEN
+
+ifeq ($(BR2_PACKAGE_ICU),y)
+ZNC_DEPENDENCIES += icu
+ZNC_CONF_OPT += --enable-icu
+else
+ZNC_CONF_OPT += --disable-icu
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ZNC_DEPENDENCIES += openssl
+ZNC_CONF_OPT += --enable-openssl
+else
+ZNC_CONF_OPT += --disable-openssl
+endif
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+ZNC_DEPENDENCIES += zlib
+ZNC_CONF_OPT += --enable-zlib
+else
+ZNC_CONF_OPT += --disable-zlib
+endif
+
+ifeq ($(BR2_PACKAGE_PYTHON3),y)
+ZNC_DEPENDENCIES += python3 host-swig
+ZNC_CONF_OPT += --enable-python=python3
+else
+ZNC_CONF_OPT += --disable-python
+endif
+
+$(eval $(autotools-package))