cjson: bug fix - use -fPIC instead of -fpic
authorDanomi Manchego <danomimanchego123@gmail.com>
Mon, 27 Aug 2012 15:58:06 +0000 (15:58 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 6 Sep 2012 20:55:08 +0000 (22:55 +0200)
This change is to fix the autobuild failure at:
http://autobuild.buildroot.net/results/45e2c08d5e3c868b2d7fdf26a7c5f88de5ff8f61/build-end.log
I can't actually reproduce this bug, because my machine cannot
run the 64-bit microblaze toolchain.  However, the log makes
it clear that -fPIC is needed, and grepping for fPIC and fpic
under packages makes it clear that cjson should have used -fPIC
anyway.  So even if the bug isn't fixed, it must surely be improved.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/cjson/cjson.mk

index 79b4c31185f77038353a079576d49d4e159f8b8c..dd640107489007711a1d1f1ca6c0c74eac10da5e 100644 (file)
@@ -14,7 +14,7 @@ define CJSON_EXTRACT_CMDS
 endef
 
 define CJSON_BUILD_CMDS
-       cd $(@D)/cJSON && $(TARGET_CC) $(TARGET_CFLAGS) -shared -fpic cJSON.c -o libcJSON.so
+       cd $(@D)/cJSON && $(TARGET_CC) $(TARGET_CFLAGS) -shared -fPIC cJSON.c -o libcJSON.so
 endef
 
 define CJSON_INSTALL_STAGING_CMDS