Revert "qt5wayland: fix build issue with mesa3d w/out xcb"
authorGaël PORTAY <gael.portay@savoirfairelinux.com>
Thu, 1 Mar 2018 21:34:26 +0000 (16:34 -0500)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 1 Apr 2018 21:48:30 +0000 (23:48 +0200)
This reverts commit 85483968bec8c5bb3332f61b22cc9be8f0ad15f7.

Supersede by:

qt5base: fix build issue with mesa3d w/out xcb

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/qt5/qt5wayland/qt5wayland.mk

index 8a7f2e1fb598cd1aa808218b26675cabcc5ce8f8..0a7bdb8cf936bba5b57d50f9d9e0aded33dffd18 100644 (file)
@@ -26,13 +26,6 @@ ifeq ($(BR2_PACKAGE_QT5WAYLAND_COMPOSITOR),y)
 QT5WAYLAND_QMAKEFLAGS += CONFIG+=wayland-compositor
 endif
 
-# The mesa's EGL/eglplatform.h header includes X11 headers unless the flag
-# MESA_EGL_NO_X11_HEADERS is defined. Tell to not include X11 headers if
-# the libxcb is not selected.
-ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL)x$(BR2_PACKAGE_LIBXCB),yx)
-QT5WAYLAND_QMAKEFLAGS += QMAKE_CXXFLAGS+=-DMESA_EGL_NO_X11_HEADERS
-endif
-
 define QT5WAYLAND_CONFIGURE_CMDS
        (cd $(@D); $(TARGET_MAKE_ENV) $(HOST_DIR)/bin/qmake $(QT5WAYLAND_QMAKEFLAGS))
 endef