package/ripgrep: fix debug build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 22 Aug 2020 18:22:37 +0000 (20:22 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 24 Aug 2020 09:02:08 +0000 (11:02 +0200)
There is no --debug mode for cargo resulting in the following build
failure since the addition of this package with commit
4b0d1ef6ac00c5170a3fb9d15d06b3d3172e0c97:

error: Unknown flag: '--debug'

Fixes:
 - http://autobuild.buildroot.org/results/58e74bb056ec65680ecebaa559aa14bdebbf5c85
 - http://autobuild.buildroot.org/results/28c6364a89a6044d5a036614f7a6e59815efb770

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: keep the default 'dev' mode when in debug]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/ripgrep/ripgrep.mk

index 832c076f26bbc4dcbe9cdf2a39970ff978930533..5f58630ffefd7a19f71d31d4ef29c7ceec32673b 100644 (file)
@@ -11,12 +11,11 @@ RIPGREP_LICENSE_FILES = LICENSE-MIT
 
 RIPGREP_DEPENDENCIES = host-rustc
 RIPGREP_CARGO_ENV = CARGO_HOME=$(HOST_DIR)/share/cargo
-RIPGREP_CARGO_MODE = $(if $(BR2_ENABLE_DEBUG),debug,release)
 
 RIPGREP_BIN_DIR = target/$(RUSTC_TARGET_NAME)/$(RIPGREP_CARGO_MODE)
 
 RIPGREP_CARGO_OPTS = \
-       --$(RIPGREP_CARGO_MODE) \
+       $(if $(BR2_ENABLE_DEBUG),,--release) \
        --target=$(RUSTC_TARGET_NAME) \
        --manifest-path=$(@D)/Cargo.toml