package/qt5/qt5base: add custom configure options last
authorJames Grant <james.grant@jci.com>
Fri, 1 Mar 2019 02:17:11 +0000 (15:17 +1300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 1 Mar 2019 09:12:36 +0000 (10:12 +0100)
This allows all options set by Buildroot to be overridden.

Signed-off-by: James Grant <james.grant@jci.com>
[Peter: drop original line as pointed out by Thomas]
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt5/qt5base/qt5base.mk

index 11c6684812c8fa412fb99cd3211d8166ca2349e7..e71878a487b105b5eedd164b6aae0c876be9edbe 100644 (file)
@@ -52,8 +52,6 @@ else
 # option '-no-avx512' (available for latest only)
 endif
 
-QT5BASE_CONFIGURE_OPTS += $(call qstrip,$(BR2_PACKAGE_QT5BASE_CUSTOM_CONF_OPTS))
-
 ifeq ($(BR2_PACKAGE_LIBDRM),y)
 QT5BASE_CONFIGURE_OPTS += -kms
 QT5BASE_DEPENDENCIES += libdrm
@@ -296,6 +294,9 @@ define QT5BASE_CONFIGURE_HOSTCC
        $(SED) 's,^QMAKE_CXX\s*=.*,QMAKE_CXX = $(HOSTCXX),' $(@D)/mkspecs/common/g++-base.conf
 endef
 
+# Must be last so can override all options set by Buildroot
+QT5BASE_CONFIGURE_OPTS += $(call qstrip,$(BR2_PACKAGE_QT5BASE_CUSTOM_CONF_OPTS))
+
 define QT5BASE_CONFIGURE_CMDS
        mkdir -p $(@D)/mkspecs/devices/linux-buildroot-g++/
        sed 's/@EGLFS_DEVICE@/$(QT5BASE_EGLFS_DEVICE)/g' \