system: make the zoneinfo list a system option
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 7 Apr 2014 19:58:03 +0000 (21:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 8 Apr 2014 21:33:24 +0000 (23:33 +0200)
[Peter: move legacy options under 2014.05]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Alexandre Belloni <alexandre.belloni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/tzdata/Config.in
package/tzdata/tzdata.mk
system/Config.in

index ce44d0f5cca45c8676f39fab77288de3008b804a..c3c430cd9295ce006b3d52482ae79f10e98c2bf7 100644 (file)
@@ -101,6 +101,21 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2014.05"
 
+config BR2_TARGET_TZ_ZONELIST
+       default BR2_PACKAGE_TZDATA_ZONELIST if BR2_PACKAGE_TZDATA_ZONELIST != ""
+
+config BR2_PACKAGE_TZDATA_ZONELIST
+       string "tzdata: the timezone list option has been renamed"
+       help
+         The option BR2_PACKAGE_TZDATA_ZONELIST has been renamed to
+         BR2_TARGET_TZ_ZONELIST, and moved to the "System configuration"
+         menu. You'll need to select BR2_TARGET_TZ_INFO.
+
+config BR2_PACKAGE_TZDATA_ZONELIST_WRAP
+       bool
+       default y if BR2_PACKAGE_TZDATA_ZONELIST != ""
+       select BR2_LEGACY
+
 config BR2_PACKAGE_LUA_INTERPRETER_EDITING_NONE
        bool "Lua command-line editing none has been renamed"
        select BR2_LEGACY
index 1be68149b5def5c832c4c8dc425a61aeafb86b98..1e6cc0fc641101e184e68f14afc03a8f9e20a74e 100644 (file)
@@ -1,26 +1,9 @@
-comment "tzdata needs an (e)glibc toolchain"
-       depends on !BR2_TOOLCHAIN_USES_GLIBC
+# This package is not meant to be user-visible.
+# It gets selected by BR2_TARGET_TZ in system/Config.in
 
 config BR2_PACKAGE_TZDATA
-       bool "tzdata"
-       depends on BR2_TOOLCHAIN_USES_GLIBC
+       bool
        help
          Time zone database
 
          http://www.iana.org/time-zones/repository/tz-link.html
-
-if BR2_PACKAGE_TZDATA
-
-config BR2_PACKAGE_TZDATA_ZONELIST
-       string "Time zone list"
-       default "default"
-       help
-         Space-separated list of time zones to compile.
-
-         The value "default" includes all commonly used time zones. Note
-         that this set consumes around 5.5M.
-
-         The full list is the list of files in the time zone database source,
-         not including the build and .tab files.
-
-endif
index d5c9f66be4a8fe5574814ec2cece276fbfedd8d7..59004736e88f171324837a243b9f73c8a8f09d24 100644 (file)
@@ -13,10 +13,10 @@ TZDATA_LICENSE = Public domain
 TZDATA_DEFAULT_ZONELIST = africa antarctica asia australasia backward etcetera \
                        europe factory northamerica pacificnew southamerica
 
-ifeq ($(call qstrip,$(BR2_PACKAGE_TZDATA_ZONELIST)),default)
+ifeq ($(call qstrip,$(BR2_TARGET_TZ_ZONELIST)),default)
 TZDATA_ZONELIST = $(TZDATA_DEFAULT_ZONELIST)
 else
-TZDATA_ZONELIST = $(call qstrip,$(BR2_PACKAGE_TZDATA_ZONELIST))
+TZDATA_ZONELIST = $(call qstrip,$(BR2_TARGET_TZ_ZONELIST))
 endif
 
 # Don't strip any path components during extraction.
index ba225cee184375a9550d0d12e575a7811239f13a..d69e880d555748ae5a8db5ebadd351102341de00 100644 (file)
@@ -267,6 +267,29 @@ config BR2_TARGET_GENERIC_GETTY_OPTIONS
 endmenu
 endif
 
+config BR2_TARGET_TZ_INFO
+       bool "Install timezone info"
+       depends on BR2_TOOLCHAIN_USES_GLIBC
+       select BR2_PACKAGE_TZDATA
+       help
+         Say 'y' here to install timezone info.
+
+if BR2_TARGET_TZ_INFO
+
+config BR2_TARGET_TZ_ZONELIST
+       string "timezone list"
+       default "default"
+       help
+         Space-separated list of time zones to compile.
+
+         The value "default" includes all commonly used time zones. Note
+         that this set consumes around 5.5M.
+
+         The full list is the list of files in the time zone database source,
+         not including the build and .tab files.
+
+endif # BR2_TARGET_TZ_INFO
+
 config BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW
        bool "remount root filesystem read-write during boot"
        default y