libnspr: use the BR2_ARM_CPU_ARMV7A option
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Oct 2014 20:27:05 +0000 (22:27 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 6 Nov 2014 22:58:36 +0000 (23:58 +0100)
The libnspr --enable-thumb2 option was only enabled on Cortex-A8 and
Cortex-A9. This commit switches to using BR2_ARM_CPU_ARMV7A instead,
which will allow using Thumb2 for this package even with the other
Cortex-A cores.

[Peter: use BR2_ARM_CPU_HAS_THUMB2 instead]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libnspr/libnspr.mk

index eaa6eb75d903c19538a29020578da56d60ab7623..c071d8591fbd255b5cb1ec609b4b5059a32a0ef5 100644 (file)
@@ -22,7 +22,7 @@ LIBNSPR_CONF_OPTS += --$(if $(BR2_ARCH_IS_64),en,dis)able-64bit
 LIBNSPR_CONF_OPTS += --$(if $(BR2_INET_IPV6),en,dis)able-ipv6
 
 ifeq ($(BR2_arm),y)
-ifeq ($(BR2_cortex_a8)$(BR2_cortex_a9),y)
+ifeq ($(BR2_ARM_CPU_HAS_THUMB2),y)
 LIBNSPR_CONF_OPTS += --enable-thumb2
 else
 LIBNSPR_CONF_OPTS += --disable-thumb2