lua-csnappy: new package
authorFrancois Perrad <fperrad@gmail.com>
Mon, 24 Feb 2014 07:34:56 +0000 (08:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 15:33:37 +0000 (16:33 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/lua-csnappy/Config.in [new file with mode: 0644]
package/lua-csnappy/lua-csnappy.mk [new file with mode: 0644]

index cc407e1389c12bf09cbe5c0ea1cfe8583d8c05c3..43c82922761cf5b0d80b68088c8732352abca383 100644 (file)
@@ -380,6 +380,7 @@ source "package/lrandom/Config.in"
 source "package/lua-cjson/Config.in"
 source "package/lua-coat/Config.in"
 source "package/lua-coatpersistent/Config.in"
+source "package/lua-csnappy/Config.in"
 source "package/lua-ev/Config.in"
 source "package/lua-messagepack/Config.in"
 source "package/lua-msgpack-native/Config.in"
diff --git a/package/lua-csnappy/Config.in b/package/lua-csnappy/Config.in
new file mode 100644 (file)
index 0000000..0562277
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LUA_CSNAPPY
+       bool "lua-csnappy"
+       help
+         lua-csnappy is a binding of the csnappy library
+         which implements the Google's Snappy (de)compressor.
+
+         http://fperrad.github.io/lua-csnappy/
+
diff --git a/package/lua-csnappy/lua-csnappy.mk b/package/lua-csnappy/lua-csnappy.mk
new file mode 100644 (file)
index 0000000..07aaf77
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# lua-csnappy
+#
+################################################################################
+
+LUA_CSNAPPY_VERSION_UPSTREAM = 0.1.1
+LUA_CSNAPPY_VERSION = $(LUA_CSNAPPY_VERSION_UPSTREAM)-1
+LUA_CSNAPPY_SUBDIR  = lua-csnappy-$(LUA_CSNAPPY_VERSION_UPSTREAM)
+LUA_CSNAPPY_LICENSE = BSD-3c
+LUA_CSNAPPY_LICENSE_FILES = $(LUA_CSNAPPY_SUBDIR)/COPYRIGHT
+
+$(eval $(luarocks-package))