gnutls: fix libgcrypt handling with external toolchains
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Jun 2012 12:00:13 +0000 (14:00 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Jun 2012 12:00:13 +0000 (14:00 +0200)
The explicit gnutls prefix in combination with the libc.so linker script
and non-default sysroot seems to confuse external toolchains, causing
configure to error out. Workaround it by not using an explicit libgcrypt
prefix as it is installed in the sysroot anyway.

Fixes http://autobuild.buildroot.net/results/3b3901bea904bf32bccbd3e9a4274d604776cb98

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gnutls/gnutls.mk

index f7238aaae20688d32b28a67f256787974722aacd..45323f2f2c6d86b99bd6b6d90b5128d8463470dc 100644 (file)
@@ -8,7 +8,7 @@ GNUTLS_VERSION = 2.12.19
 GNUTLS_SOURCE = gnutls-$(GNUTLS_VERSION).tar.bz2
 GNUTLS_SITE = $(BR2_GNU_MIRROR)/gnutls
 GNUTLS_DEPENDENCIES = host-pkg-config libgcrypt
-GNUTLS_CONF_OPT = --with-libgcrypt --with-libgcrypt-prefix=$(STAGING_DIR)/usr \
+GNUTLS_CONF_OPT = --with-libgcrypt \
                --without-p11-kit
 GNUTLS_INSTALL_STAGING = YES