libsemanage: bump to version 2.5
authorAdam Duskett <Aduskett@gmail.com>
Sun, 26 Jun 2016 22:39:09 +0000 (18:39 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Jul 2016 09:06:23 +0000 (11:06 +0200)
The 0001-execption-lib-path-fix.patch is also no longer needed, as the
new version of libsemanage includes the fix provided by the patch.
As such, the patch was removed, and 0002 was renamed to 0001.

Audit was added as a dependency as the new version of libsemanage
will fail to compile searching for audit.h

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[Thomas: add the select on audit + propagate the dependencies.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libsemanage/0001-execption-lib-path-fix.patch [deleted file]
package/libsemanage/0001-workaround-blackfin-issue.patch [new file with mode: 0644]
package/libsemanage/0002-workaround-blackfin-issue.patch [deleted file]
package/libsemanage/Config.in
package/libsemanage/libsemanage.hash
package/libsemanage/libsemanage.mk

diff --git a/package/libsemanage/0001-execption-lib-path-fix.patch b/package/libsemanage/0001-execption-lib-path-fix.patch
deleted file mode 100644 (file)
index cbcbea5..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-Patch to correct a missing header file issue.
-
-Signed-off-by Clayton Shotwell <clshotwe@rockwellcollins.com>
-
---- a/src/exception.sh 2011-12-21 11:46:04.000000000 -0600
-+++ b/src/exception.sh 2012-08-27 11:29:58.000000000 -0500
-@@ -9,6 +9,6 @@
- }
- "
- }
--gcc -x c -c - -aux-info temp.aux < ../include/semanage/semanage.h
-+gcc -x c -c - -aux-info temp.aux -I../include < ../include/semanage/semanage.h
- for i in `awk '/extern int/ { print $6 }' temp.aux`; do except $i ; done
- rm -f -- temp.aux -.o
diff --git a/package/libsemanage/0001-workaround-blackfin-issue.patch b/package/libsemanage/0001-workaround-blackfin-issue.patch
new file mode 100644 (file)
index 0000000..7ce9606
--- /dev/null
@@ -0,0 +1,25 @@
+Do not make symbols hidden on Blackfin
+
+The libselinux logic to hide internal symbols from the DSO doesn't
+work properly on Blackfin due to the USER_LABEL_PREFIX not being
+handled properly. A real fix is not that simple, so this patch simply
+disables the internal symbol hiding mechanism. This means that those
+symbols are visible in the final DSO, which is not a problem for
+proper execution, it just isn't as clean.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Signed-off-by: Adam Duskett <Aduskett@gmail.com>
+
+Index: b/src/dso.h
+===================================================================
+--- a/src/dso.h
++++ b/src/dso.h
+@@ -1,7 +1,7 @@
+ #ifndef _SEPOL_DSO_H
+ #define _SEPOL_DSO_H  1
+-#ifdef SHARED
++#if defined(SHARED) && !defined(__bfin__)
+ # define hidden __attribute__ ((visibility ("hidden")))
+ # define hidden_proto(fct) __hidden_proto (fct, fct##_internal)
+ # define __hidden_proto(fct, internal)        \
diff --git a/package/libsemanage/0002-workaround-blackfin-issue.patch b/package/libsemanage/0002-workaround-blackfin-issue.patch
deleted file mode 100644 (file)
index 5d00c69..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-Do not make symbols hidden on Blackfin
-
-The libselinux logic to hide internal symbols from the DSO doesn't
-work properly on Blackfin due to the USER_LABEL_PREFIX not being
-handled properly. A real fix is not that simple, so this patch simply
-disables the internal symbol hiding mechanism. This means that those
-symbols are visible in the final DSO, which is not a problem for
-proper execution, it just isn't as clean.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/src/dso.h
-===================================================================
---- a/src/dso.h
-+++ b/src/dso.h
-@@ -1,7 +1,7 @@
- #ifndef _SELINUX_DSO_H
- #define _SELINUX_DSO_H        1
--#ifdef SHARED
-+#if defined(SHARED) && !defined(__bfin__)
- # define hidden __attribute__ ((visibility ("hidden")))
- # define hidden_proto(fct) __hidden_proto (fct, fct##_internal)
- # define __hidden_proto(fct, internal)        \
index 4465ef46d88648b01c74cd33b0d489ebc8df9aed..4318dbfc5f1721f767b5b015564f06525340e16d 100644 (file)
@@ -1,12 +1,15 @@
 config BR2_PACKAGE_LIBSEMANAGE
        bool "libsemanage"
+       select BR2_PACKAGE_AUDIT
        select BR2_PACKAGE_LIBSELINUX
        select BR2_PACKAGE_USTR
        select BR2_PACKAGE_BZIP2
+       depends on BR2_PACKAGE_AUDIT_ARCH_SUPPORTS
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on !BR2_STATIC_LIBS
-       # libselinux needs fts.h (not available in uClibc/musl) and
-       # libsemanage itself needs getpwent_r() not available in musl
+       # - libselinux needs fts.h (not available in uClibc/musl)
+       # - libsemanage itself needs getpwent_r() not available in musl
+       # - audit is not available on musl
        depends on BR2_TOOLCHAIN_USES_GLIBC
        depends on !BR2_arc
        help
@@ -22,5 +25,6 @@ config BR2_PACKAGE_LIBSEMANAGE
 
 comment "libsemanage needs a glibc toolchain w/ threads, dynamic library"
        depends on !BR2_arc
+       depends on BR2_PACKAGE_AUDIT_ARCH_SUPPORTS
        depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS || \
                !BR2_TOOLCHAIN_USES_GLIBC
index d4204d1b62b6abfa04e33c9bdaf287e7c77510c9..69f7c8d3aefe359ed71a2a86aacad10b3280b560 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256 de2e8077245581e94576276f54e80a53c23c28d6961d2dfbe2f004eaba452e91 libsemanage-2.1.10.tar.gz
+sha256 46e2f36254369b6e91d1eea0460c262b139361b055a3a67d3ceea2d8ef72e006 libsemanage-2.5.tar.gz
index 197c14e4229aac7bb56e042863e28e9cb5480979..a60d0186980b3e5b658095e2da914769c3dc236b 100644 (file)
@@ -4,11 +4,11 @@
 #
 ################################################################################
 
-LIBSEMANAGE_VERSION = 2.1.10
-LIBSEMANAGE_SITE = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20130423
+LIBSEMANAGE_VERSION = 2.5
+LIBSEMANAGE_SITE = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223
 LIBSEMANAGE_LICENSE = LGPLv2.1+
 LIBSEMANAGE_LICENSE_FILES = COPYING
-LIBSEMANAGE_DEPENDENCIES = host-bison host-flex libselinux ustr bzip2
+LIBSEMANAGE_DEPENDENCIES = host-bison host-flex audit libselinux ustr bzip2
 LIBSEMANAGE_INSTALL_STAGING = YES
 
 LIBSEMANAGE_MAKE_OPTS = $(TARGET_CONFIGURE_OPTS)