qt: remove Kconfig option to enable all pixel depths
authorMichael Roth <mroth@nessie.de>
Wed, 7 Oct 2009 09:20:41 +0000 (11:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 9 Oct 2009 12:56:42 +0000 (14:56 +0200)
The Kconfig menu "Pixel depths" of Qt provides a list with all
selectable pixel depths and additionally the option "all".

When "all" is selected, the list with all available pixel depths
disappears.

Because this disappearing of available pixel depths makes no sense
under usability aspects, simply remove the option "all".

The user could enable all available pixel depths by selecting each
individual depth anyway. So no functionality is lost.

Signed-off-by: Michael Roth <mroth@nessie.de>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
configs/atstk100x_defconfig
configs/v100sc2_defconfig
package/qt/Config.in
package/qt/qt.mk

index 7b6d4260037ee2e16598b13dd6a112cc403e72e1..920789530c691eac52385e62fb7c3b6cba47544b 100644 (file)
@@ -702,7 +702,6 @@ BR2_PACKAGE_QT_GUI_MODULE=y
 #
 # Deselecting each option leads to Qt's default (8,16,32)
 #
-# BR2_PACKAGE_QT_PIXEL_DEPTH_ALL is not set
 # BR2_PACKAGE_QT_PIXEL_DEPTH_1 is not set
 # BR2_PACKAGE_QT_PIXEL_DEPTH_4 is not set
 BR2_PACKAGE_QT_PIXEL_DEPTH_8=y
index f444951ae256f65fafac39dac7e97a4151af3ab5..fcece77b04d537aff0f36f5d07f0d2a489744e73 100644 (file)
@@ -550,7 +550,9 @@ BR2_PACKAGE_QT_LICENSE_TYPE_GPL=y
 # BR2_PACKAGE_QT_LICENSE_TYPE_COMMERCIAL is not set
 BR2_PACKAGE_QT_GPL_LICENSE_APPROVED=y
 # BR2_PACKAGE_QT_QT3SUPPORT is not set
-BR2_PACKAGE_QT_DEPTHS="-depths 24,16,8"
+BR2_PACKAGE_QT_PIXEL_DEPTH_8=y
+BR2_PACKAGE_QT_PIXEL_DEPTH_16=y
+BR2_PACKAGE_QT_PIXEL_DEPTH_24=y
 BR2_PACKAGE_QT_GIF=y
 # BR2_PACKAGE_QT_LIBMNG is not set
 # BR2_PACKAGE_QT_NOJPEG is not set
index b7fe0f93933f42be73de43427c54e3e3b6e766a4..d25ebf94c2acb8c13b4aef279990fa14e5ea7a9e 100644 (file)
@@ -87,11 +87,6 @@ if BR2_PACKAGE_QT_GUI_MODULE
 menu "Pixel depths"
 comment "Deselecting each option leads to Qt's default (8,16,32)"
 
-config BR2_PACKAGE_QT_PIXEL_DEPTH_ALL
-       bool "All supported depths"
-
-if !BR2_PACKAGE_QT_PIXEL_DEPTH_ALL
-
 config BR2_PACKAGE_QT_PIXEL_DEPTH_1
        bool "1 bpp, black/white"
 
@@ -122,7 +117,6 @@ config BR2_PACKAGE_QT_PIXEL_DEPTH_32
        bool "32 bpp, argb 8-8-8-8 and rgb 8-8-8"
        default y
 
-endif
 endmenu
 endif
 
index ae03fa6843e5d4df5f5327552feae5019ab92645..0bbf64405c8ef32ebdf7843e23c89901055517f1 100644 (file)
@@ -62,9 +62,7 @@ endif
 
 
 ### Pixel depths
-ifeq ($(BR2_PACKAGE_QT_PIXEL_DEPTH_ALL),y)
-QT_PIXEL_DEPTHS = all
-else
+QT_PIXEL_DEPTHS := # empty
 ifeq ($(BR2_PACKAGE_QT_PIXEL_DEPTH_1),y)
 QT_PIXEL_DEPTHS += 1
 endif
@@ -92,7 +90,6 @@ endif
 ifeq ($(BR2_PACKAGE_QT_PIXEL_DEPTH_32),y)
 QT_PIXEL_DEPTHS += 32
 endif
-endif
 ifneq ($(QT_PIXEL_DEPTHS),)
 QT_CONFIGURE += -depths $(subst $(space),$(comma),$(strip $(QT_PIXEL_DEPTHS)))
 endif