boot/uboot: fix environment image generation on big endian systems
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 14 Oct 2018 19:11:58 +0000 (21:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 14 Oct 2018 19:11:58 +0000 (21:11 +0200)
As reported by Jeff Wittrock in bug #11396, the U-Boot environment
image checksum is invalid for big endian targets, because the test on
the BR2_ENDIAN Config.in option doesn't take into account that it is
double quoted.

The fix was provided by Jeff himself on bugzilla.

Fixes bug #11396.

Reported-by: Jeff Wittrock <jwittrock@faultrecorder.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/uboot/uboot.mk

index c5abc125f3ea34897ec7486beed4cdd1c7ea9152..fa92eafff59f197f891643e093e807644052c7a9 100644 (file)
@@ -267,7 +267,7 @@ define UBOOT_GENERATE_ENV_IMAGE
                >$(@D)/buildroot-env.txt
        $(HOST_DIR)/bin/mkenvimage -s $(BR2_TARGET_UBOOT_ENVIMAGE_SIZE) \
                $(if $(BR2_TARGET_UBOOT_ENVIMAGE_REDUNDANT),-r) \
-               $(if $(filter BIG,$(BR2_ENDIAN)),-b) \
+               $(if $(filter "BIG",$(BR2_ENDIAN)),-b) \
                -o $(BINARIES_DIR)/uboot-env.bin \
                $(@D)/buildroot-env.txt
 endef