package/ebtables: drop useless EBTABLES_SUBDIR variable
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 22 Dec 2019 20:15:33 +0000 (21:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 22 Dec 2019 21:25:58 +0000 (22:25 +0100)
This variable is never defined, so it is empty. Using it makes the
code needlessly more complicated than it needs to be, so let's drop
it.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ebtables/ebtables.mk

index aae0c91a10f536a34adf9280ee9d83f0c2ba31e7..7b2264703c275bbc72acf40ac3d0fab7b0c5dd78 100644 (file)
@@ -19,19 +19,15 @@ endef
 
 ifeq ($(BR2_STATIC_LIBS),y)
 define EBTABLES_INSTALL_TARGET_CMDS
-       $(INSTALL) -m 0755 -D $(@D)/$(EBTABLES_SUBDIR)/static \
-               $(TARGET_DIR)/sbin/ebtables
+       $(INSTALL) -m 0755 -D $(@D)/static $(TARGET_DIR)/sbin/ebtables
 endef
 else
 define EBTABLES_INSTALL_TARGET_CMDS
-       for so in $(@D)/$(EBTABLES_SUBDIR)/*.so \
-               $(@D)/$(EBTABLES_SUBDIR)/extensions/*.so; \
-               do \
+       for so in $(@D)/*.so $(@D)/extensions/*.so; do \
                $(INSTALL) -m 0755 -D $${so} \
                        $(TARGET_DIR)/lib/ebtables/`basename $${so}` || exit 1; \
        done
-       $(INSTALL) -m 0755 -D $(@D)/$(EBTABLES_SUBDIR)/ebtables \
-               $(TARGET_DIR)/sbin/ebtables
+       $(INSTALL) -m 0755 -D $(@D)/ebtables $(TARGET_DIR)/sbin/ebtables
        $(INSTALL) -m 0644 -D $(@D)/ethertypes $(TARGET_DIR)/etc/ethertypes
 endef
 endif