wolfssl: fix build on ARMV8
authorSergio Prado <sergio.prado@e-labworks.com>
Mon, 15 Jan 2018 14:48:10 +0000 (12:48 -0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 15 Jan 2018 20:24:35 +0000 (21:24 +0100)
Build on ARMV8 fails when hardware acceleration is enabled:

/tmp/ccmGP5RI.s: Assembler messages:
/tmp/ccmGP5RI.s:532: Error: invalid addressing mode at operand 2 -- `ld1 {v0.2d},[x0,256]'
/tmp/ccmGP5RI.s:568: Error: invalid addressing mode at operand 2 -- `st1 {v0.2d},[x0,256]'
/tmp/ccmGP5RI.s:581: Error: invalid addressing mode at operand 2 -- `ld1 {v0.2d},[x0,256]'
/tmp/ccmGP5RI.s:621: Error: invalid addressing mode at operand 2 -- `st1 {v0.2d},[x0,256]'

So let's disable ARMv8 hardware acceleration for now.

Fixes:
http://autobuild.buildroot.net/results/6080648394d09a0d382087831ee6f063c7638be9

Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wolfssl/wolfssl.mk

index c8ef50a9bc6e361e858e3c9e1cf7c093ed292873..84073f338e7654e3a9b6b1540e0548587ae2d821 100644 (file)
@@ -29,10 +29,7 @@ else
 WOLFSSL_CONF_OPTS += --disable-sslv3
 endif
 
-ifeq ($(BR2_ARM_CPU_ARMV8A),y)
-WOLFSSL_CONF_OPTS += --enable-armasm
-else
+# build fails when ARMv8 hardware acceleration is enabled
 WOLFSSL_CONF_OPTS += --disable-armasm
-endif
 
 $(eval $(autotools-package))