package/quagga: fix static linking with getopt
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 1 Aug 2019 16:24:08 +0000 (18:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 2 Aug 2019 08:29:07 +0000 (10:29 +0200)
quagga has its own copy of getopt_long() instead of using the system's,
and this copy also defines the opterr and optind variables. Obviously,
this is only apparent when linking statically.

This problem can easily be avoided by making sure that getopt() itself
is defined too. This way, there is no reason any more to pull in libc's
getopt() and the corresponding definitions of opterr and optind. Note
that getopt() itself is pulled in by netsnmp, not by quagga itself.

Fortunately, there's a REALLY_NEED_PLAIN_GETOPT flag that we can define
to make sure getopt() does get built by quagga. We can safely do this
unconditionally (instead of only when BR2_PACKAGE_QUAGGA_SNMP and
BR2_STATIC_LIBS are enabled): without netsnmp, getopt() will simply not
be used, and with dynamic libs there's no risk of conflicts anyway.

Fixes:
http://autobuild.buildroot.net/results/0ac598c2259a8d7e8b72d4e8ed95079675b31b84

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/quagga/quagga.mk

index 420d72c79d43a3f2926e83c3c9861454f98e5e57..8aa58aceef2476a083a6d16a72370feadff16b58 100644 (file)
@@ -18,6 +18,11 @@ QUAGGA_CONF_OPTS = \
        --sysconfdir=/etc/quagga \
        --localstatedir=/var/run/quagga
 
+# quagga has its own internal copy of getopt_long. To avoid conflicts with libc's
+# getopt, we need to make sure that the getopt function itself is also built.
+QUAGGA_CONF_ENV = \
+       CFLAGS="$(TARGET_CFLAGS) -DREALLY_NEED_PLAIN_GETOPT"
+
 ifeq ($(BR2_PACKAGE_LIBCAP),y)
 QUAGGA_CONF_OPTS += --enable-capabilities
 QUAGGA_DEPENDENCIES += libcap