libmbus : bump version to 0.8
authorSagaert Johan <sagaert.johan@skynet.be>
Mon, 5 Nov 2012 15:20:03 +0000 (15:20 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 7 Nov 2012 19:38:37 +0000 (20:38 +0100)
This release contains many improvements bug fixes, and major new features and
support for float point numbers and support for multi-telegram communication...

[Peter: also drop autoreconf]
Signed-off-by: Sagaert Johan <sagaert.johan@skynet.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libmbus/libmbus-bcopy.patch [deleted file]
package/libmbus/libmbus.mk

diff --git a/package/libmbus/libmbus-bcopy.patch b/package/libmbus/libmbus-bcopy.patch
deleted file mode 100644 (file)
index 660cc37..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-Drop bcopy since it's deprecated.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura libmbus-0.7.0/mbus/mbus-tcp.c libmbus-0.7.0-bcopy/mbus/mbus-tcp.c
---- libmbus-0.7.0/mbus/mbus-tcp.c      2011-12-08 13:21:19.000000000 -0300
-+++ libmbus-0.7.0-bcopy/mbus/mbus-tcp.c        2012-05-03 09:08:36.987106612 -0300
-@@ -78,7 +78,7 @@
-         return NULL;
-     }
--    bcopy((void *)(host_addr->h_addr), (void *)(&s.sin_addr), host_addr->h_length);
-+    memmove((void *)(&s.sin_addr), (void *)(host_addr->h_addr), host_addr->h_length);
-     if (connect(handle->sock, (struct sockaddr *)&s, sizeof(s)) < 0)
-     {
index 16e9e6a0bc8d276a70c6bf20362b03678c6ecba1..b3cae97e8e943a5a8cee50eb1911c4a8e6036980 100644 (file)
@@ -4,12 +4,8 @@
 #
 #############################################################
 
-LIBMBUS_VERSION = 0.7.0
+LIBMBUS_VERSION = 0.8.0
 LIBMBUS_SITE = http://www.freescada.com/public-dist
 LIBMBUS_INSTALL_STAGING = YES
 
-# Without this the build yields an error:
-#   cannot find input file: `test/Makefile.in'
-LIBMBUS_AUTORECONF = YES
-
 $(eval $(autotools-package))