package/libpjsip: disable remaining unspecified options
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 5 Jan 2017 21:16:37 +0000 (22:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Jan 2017 03:39:22 +0000 (16:39 +1300)
There are a bunch of options that are left unspecified; explicitly
disable them.

The epoll case is special: the configure script is broken, and will
enable it whether we pass --enable-epoll or --disable-epoll. But that's
OK because we prefer epoll over the alternative (select). So we do not
need to fix it. Which is nice becasue the configure.ac is named
aconfigure.ac (yes, with a leading 'a'), so it does not autoreconf
nicely... :-/

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Luca Ceresoli <luca@lucaceresoli.net>
Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libpjsip/libpjsip.mk

index cb0d866e255b06a3fb0342f9b6839dee6416dca1..70dd4aa2472d886b0005e4fd4abf33699a2accab 100644 (file)
@@ -36,8 +36,29 @@ LIBPJSIP_CONF_OPTS = \
        --disable-ilbc-codec \
        --disable-webrtc \
        --disable-opus \
+       --disable-oss \
+       --disable-ext-sound \
+       --disable-small-filter \
+       --disable-large-filter \
+       --disable-g711-codec \
+       --disable-l16-codec \
+       --disable-g722-codec \
+       --disable-libsamplerate \
+       --disable-sdl \
+       --disable-ffmpeg \
+       --disable-v4l2 \
+       --disable-openh264 \
+       --disable-libyuv \
+       --disable-ipp \
+       --disable-ssl \
+       --disable-silk \
        --with-external-srtp=$(STAGING_DIR)/usr
 
+# Note: aconfigure.ac is broken: --enable-epoll or --disable-epoll will
+# both enable it. But that's OK, epoll is better than the alternative,
+# so we want to use it.
+LIBPJSIP_CONF_OPTS += --enable-epoll
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBPJSIP_DEPENDENCIES += openssl
 LIBPJSIP_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr