Part of NcFTP depends on ncurses, create dependencies, if needed
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 25 Jan 2009 08:18:35 +0000 (08:18 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 25 Jan 2009 08:18:35 +0000 (08:18 -0000)
package/ncftp/Config.in
package/ncftp/ncftp.mk

index d7c63ba0e60b3b4568f724b1feb54aa5b38203ef..652825de1cd51c7542ef195b1afbb7e670f64eef 100644 (file)
@@ -30,11 +30,13 @@ config BR2_PACKAGE_NCFTP_BATCH
        depends on BR2_PACKAGE_NCFTP
 
 config BR2_PACKAGE_NCFTP_SPOOLER
-       bool "NcFTPSpooler - spooler - not working properly"
+       bool "NcFTPSpooler - spooler"
        depends on BR2_PACKAGE_NCFTP
+       depends on BR2_PACKAGE_NCURSES
 
 config BR2_PACKAGE_NCFTP_BOOKMARKS
-       bool "NcFTPBookmarks - not working properly"
+       bool "NcFTPBookmarks"
        depends on BR2_PACKAGE_NCFTP
+       depends on BR2_PACKAGE_NCURSES
 
 endmenu
index 70f0fd6183d22838d1d56d9c10e2d1507332f292..4a4a9a64300ca212ef8da1f5debfd6b4d0b6cce5 100644 (file)
@@ -26,15 +26,20 @@ ifeq ($(BR2_PACKAGE_NCFTP_BATCH),y)
 NCFTP_TARGET_BINS+=ncftpbatch
 endif
 
+ifeq ($(BR2_PACKAGE_NCURSES),y)
 ifeq ($(BR2_PACKAGE_NCFTP_SPOOLER),y)
 #Someone needs to figure out what to do...
 NCFTP_TARGET_BINS+=
 endif
 
+# only set if NCURSES is available
 ifeq ($(BR2_PACKAGE_NCFTP_BOOKMARKS),y)
 NCFTP_TARGET_BINS+=ncftpbookmarks
 endif
 
+NCFTP_DEPS += ncurses
+endif
+
 ncftp-source: $(DL_DIR)/$(NCFTP_SOURCE)
 
 $(DL_DIR)/$(NCFTP_SOURCE):
@@ -64,7 +69,7 @@ $(TARGET_DIR)/usr/bin/ncftp $(TARGET_DIR)/usr/bin/ncftp%: $(addprefix $(NCFTP_DI
        $(INSTALL) -m 0755 $(NCFTP_DIR)/bin/$(notdir $@) $(TARGET_DIR)/usr/bin
        $(STRIPCMD) $(STRIP_STRIP_ALL) $@
 
-ncftp: uclibc $(addprefix $(TARGET_DIR)/usr/bin/, $(NCFTP_TARGET_BINS))
+ncftp: uclibc $(NCFTP_DEPS) $(addprefix $(TARGET_DIR)/usr/bin/, $(NCFTP_TARGET_BINS))
 
 ncftp-clean:
        -$(MAKE) -C $(NCFTP_DIR) clean