package/libamcodec: remove package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 10 Aug 2019 10:59:55 +0000 (12:59 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 11 Aug 2019 12:28:34 +0000 (14:28 +0200)
Package is not needed anymore after support for odroid2c was dropped:
https://git.buildroot.net/buildroot/commit/?id=b80712a16ae3deb65331a7923aa878e13e2e66b6

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
DEVELOPERS
package/Config.in
package/libamcodec/Config.in [deleted file]
package/libamcodec/libamcodec.hash [deleted file]
package/libamcodec/libamcodec.mk [deleted file]

index dd396d4d56a670975ec94a11874c39e5bd7a7fc9..190b98f5a5a1480dcd3701c1c48eb9badce96c4b 100644 (file)
@@ -146,6 +146,13 @@ endif
 
 comment "Legacy options removed in 2019.08"
 
+config BR2_PACKAGE_LIBAMCODEC
+       bool "liamcodec package was removed"
+       select BR2_LEGACY
+       help
+         Support for odroidc2 based systems was removed, making the
+         libamcodec package useless.
+
 config BR2_PACKAGE_ODROID_SCRIPTS
        bool "odroid-scripts package was removed"
        select BR2_LEGACY
index a8fba2520ee2da6a76c60a3d80cd266642fa0036..7f62b3addf9e140cd70f33ed9e3c1c55e5f9a5c0 100644 (file)
@@ -577,9 +577,6 @@ N:  Cyril Bur <cyrilbur@gmail.com>
 F:     arch/Config.in.powerpc
 F:     package/kvm-unit-tests
 
-N:     Dagg Stompler <daggs@gmx.com>
-F:     package/libamcodec/
-
 N:     Daniel J. Leach <dleach@belcan.com>
 F:     package/dacapo/
 
index 6a65daed11f0132f393cf8348b00fedac35e86a2..710ed12be03eae596ef5d6556636e16093329ab6 100644 (file)
@@ -1504,7 +1504,6 @@ menu "Multimedia"
        source "package/bitstream/Config.in"
        source "package/kvazaar/Config.in"
        source "package/libaacs/Config.in"
-       source "package/libamcodec/Config.in"
        source "package/libass/Config.in"
        source "package/libbdplus/Config.in"
        source "package/libbluray/Config.in"
diff --git a/package/libamcodec/Config.in b/package/libamcodec/Config.in
deleted file mode 100644 (file)
index 45846e6..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-comment "libamcodec needs a toolchain w/ threads, dynamic library"
-       depends on BR2_arm || BR2_aarch64
-       depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
-
-config BR2_PACKAGE_LIBAMCODEC
-       bool "libamcodec"
-       depends on BR2_arm || BR2_aarch64
-       depends on BR2_TOOLCHAIN_HAS_THREADS # alsa-lib
-       depends on !BR2_STATIC_LIBS # dlfcn.h
-       select BR2_PACKAGE_ALSA_LIB
-       help
-         Interface library for Amlogic media codecs
-
-         https://github.com/mdrjr/c2_aml_libs.git
diff --git a/package/libamcodec/libamcodec.hash b/package/libamcodec/libamcodec.hash
deleted file mode 100644 (file)
index a76d20a..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# Locally computed hash
-sha256 2c9812154b6dfd6a6c9c43aa334d0d03f299379fdf83c20121ad3f3d3f97c666  libamcodec-296f39bc6fc47ddf5d88b9fd3cfb82a5b39048ca.tar.gz
diff --git a/package/libamcodec/libamcodec.mk b/package/libamcodec/libamcodec.mk
deleted file mode 100644 (file)
index 3fab228..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-################################################################################
-#
-# libamcodec
-#
-################################################################################
-
-LIBAMCODEC_VERSION = 296f39bc6fc47ddf5d88b9fd3cfb82a5b39048ca
-LIBAMCODEC_SITE = $(call github,mdrjr,c2_aml_libs,$(LIBAMCODEC_VERSION))
-LIBAMCODEC_DEPENDENCIES = alsa-lib
-LIBAMCODEC_LICENSE = Unclear
-LIBAMCODEC_INSTALL_STAGING = YES
-
-# This package uses the AML_LIBS_STAGING_DIR variable to construct the
-# header and library paths used when compiling
-define LIBAMCODEC_BUILD_CMDS
-       $(foreach d,amavutils amadec amcodec,\
-               $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
-                       -C $(@D)/$(d) AML_LIBS_STAGING_DIR=$(STAGING_DIR)
-       )
-endef
-
-define LIBAMCODEC_INSTALL_STAGING_CMDS
-       $(INSTALL) -D -m 0755 $(@D)/amavutils/libamavutils.so $(STAGING_DIR)/usr/lib/libamavutils.so
-       $(INSTALL) -D -m 0555 $(@D)/amadec/libamadec.so $(STAGING_DIR)/usr/lib/libamadec.so
-       $(INSTALL) -D -m 0555 $(@D)/amcodec/libamcodec.so $(STAGING_DIR)/usr/lib/libamcodec.so
-       mkdir -p $(STAGING_DIR)/usr/include/amcodec
-       cp -rf $(@D)/amcodec/include/* $(STAGING_DIR)/usr/include/amcodec
-endef
-
-define LIBAMCODEC_INSTALL_TARGET_CMDS
-       $(INSTALL) -D -m 0755 $(@D)/amavutils/libamavutils.so $(TARGET_DIR)/usr/lib/libamavutils.so
-       $(INSTALL) -D -m 0555 $(@D)/amadec/libamadec.so $(TARGET_DIR)/usr/lib/libamadec.so
-       $(INSTALL) -D -m 0555 $(@D)/amcodec/libamcodec.so $(TARGET_DIR)/usr/lib/libamcodec.so
-endef
-
-$(eval $(generic-package))