toolchain: remove the old BR2_VFP_FLOAT option
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 16 Jul 2013 08:03:17 +0000 (10:03 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 16 Jul 2013 13:13:57 +0000 (15:13 +0200)
Now that we have a much better way of selecting between the various
VFP versions and capabilities, the BR2_VFP_FLOAT version no longer
makes sense. This commit gets rid of it, and adds the appropriate
Config.in.legacy code.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Config.in.legacy
toolchain/toolchain-buildroot/Config.in.2
toolchain/toolchain-external/ext-tool.mk
toolchain/toolchain-external/ext-toolchain-wrapper.c

index 01bf90063e5af2e52a82e0929305eb921579d9ea..b92b656fc5130705e80f6ed8a57ba1a369226e50 100644 (file)
@@ -76,6 +76,15 @@ config BR2_ELF2FLT
          BR2_PACKAGE_HOST_ELF2FLT due to the conversion of elf2flt to
          the package infrastructure.
 
+config BR2_VFP_FLOAT
+       bool "the ARM VFP floating point option has been renamed"
+       select BR2_LEGACY
+       help
+         Due to a major refactoring of the floating-point handling of
+         the ARM architecture support, the BR2_VFP_FLOAT option has
+         been replaced with a choice of options that allows to select
+         between various VFP versions/capabilities.
+
 ###############################################################################
 comment "Legacy options removed in 2013.05"
 
index e223d9d40e1f42c22f834b8909f0ee737d372e25..a9c102f7f8f7af0e1825e4346092583af7fce622 100644 (file)
@@ -28,16 +28,4 @@ config BR2_TOOLCHAIN_BUILDROOT_USE_SSP
 
 source "package/elf2flt/Config.in.host"
 
-config BR2_VFP_FLOAT
-       bool "Use ARM Vector Floating Point unit"
-       depends on !BR2_SOFT_FLOAT
-       depends on BR2_arm || BR2_armeb
-       help
-         Setting this option will enable the "-mfpu=vfp" option.
-         If your ARM CPU has a Vector Floating Point Unit (VFP)
-         and the toolchain supports the option, then the
-         code can be optimized.
-
-         Most people will answer N.
-
 endif
index 9d3dec41791b3e9e7c1d8bd3f4c8a4a50b29b603..67fc40d095fdc66b381736ee1292167d65894350 100644 (file)
@@ -196,11 +196,6 @@ TOOLCHAIN_EXTERNAL_CFLAGS += -msoft-float
 TOOLCHAIN_EXTERNAL_WRAPPER_ARGS += -DBR_SOFTFLOAT=1
 endif
 
-ifeq ($(BR2_VFP_FLOAT),y)
-TOOLCHAIN_EXTERNAL_CFLAGS += -mfpu=vfp
-TOOLCHAIN_EXTERNAL_WRAPPER_ARGS += -DBR_VFPFLOAT=1
-endif
-
 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_DOWNLOAD),y)
 TOOLCHAIN_EXTERNAL_DEPENDENCIES = $(TOOLCHAIN_EXTERNAL_DIR)/.extracted
 endif
index f81aed4935e063124122a5e7d61469fab713ab5b..afca6fab20412e7f6560f05db95ef44b0fd2d72b 100644 (file)
@@ -47,9 +47,6 @@ static char *predef_args[] = {
 #ifdef BR_SOFTFLOAT
        "-msoft-float",
 #endif /* BR_SOFTFLOAT */
-#ifdef BR_VFPFLOAT
-       "-mfpu=vfp",
-#endif /* BR_VFPFLOAT */
 #ifdef BR_64
        "-m64",
 #endif